Bug 1024951 - sysprep file parsing error at install
sysprep file parsing error at install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Frantisek Kobzik
virt
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 11:56 EDT by Tomas Jamrisko
Modified: 2013-11-20 08:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 11:12:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-10-30 11:56:26 EDT
Description of problem:
Creation of a windows 7 VM from template fails because ,,Windows could not parse or process unattend answer file [a:\sysprep.inf] for pass [oobeSystem]. The settings specified in the answer file could not be applied..." 

Looking at the answer file it seems that AdministratorPassword key is getting a hash, where it is expecting plaintext at two places. 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.28.beta1.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a new windows VM from template

Actual results:
Creation fails, probably because of the inconsistency 

Expected results:
VM should be setup properly.

Additional info:
This worked on previous builds on 3.3
Comment 1 Frantisek Kobzik 2013-11-07 11:12:02 EST
In this particular setup the mismatched value of the password was caused by manual pki data replacement after engine install. The engine stores passwords in encrypted form in the db. After the pki data has been replaced, the password couldn't be decrypted anymore.

Note You need to log in before you can comment on or make changes to this bug.