Bug 1024972 - bind using qpid-config succeeds on exclusive queue
bind using qpid-config succeeds on exclusive queue
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
medium Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Petr Matousek
:
Depends On:
Blocks: 1150626
  Show dependency treegraph
 
Reported: 2013-10-30 13:02 EDT by Petr Matousek
Modified: 2014-10-08 10:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-25.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1150626 (view as bug list)
Environment:
Last Closed: 2014-09-24 11:09:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5280 None None None Never

  None (edit)
Description Petr Matousek 2013-10-30 13:02:17 EDT
Description of problem:

When a binding request is send using address string to an exclusive queue (held by another session) the request fails with resource-locked exception (as expected). But when the binding request is issued by qpid-tools (qpid-config) no exception is received and the binding is created.

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-23.el6

How reproducible:
100%

Steps to Reproduce:
1. $cppapi/drain -t 10 "q;{create:receiver, node:{x-declare:{'exclusive': True}}}" & 
2. $cppapi/drain "q;{create:always,node:{x-bindings: [{ exchange: 'amq.direct', key: '' }]}}"
3. resource-locked exception (expected)
4. qpid-config bind amq.direct q
5. no exception, binding created (expected resource-locked exception)

Actual results:
bind using qpid-config succeeds for exclusive queue (declared by another session)

Expected results:
bind command fails with resource-locked exception

Additional info:
Comment 1 Gordon Sim 2013-10-31 10:16:05 EDT
Fixed upstream: https://svn.apache.org/r1537498

Note that this is a general issue with bind/unbind and exclusive queues. E.g. if you change the address in step 2. above to "amq.direct; {create:always, node:{x-bindings:[{queue:q}]}}" it will succeed in creating the binding. The reason it fails is due to the subscribe request when the node is the queue, not the bind request.
Comment 6 Petr Matousek 2013-11-12 11:00:40 EST
This issue has been fixed (tested both amqp0-10/1.0). 
Verified on rhel6.4 (i386, x86_64).

packages used for testing:
qpid-cpp-*-0.22-25.el6
Comment 7 errata-xmlrpc 2014-09-24 11:09:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.