Bug 1024982 - EJB client makes unnecessary write() calls
EJB client makes unnecessary write() calls
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: EAP 6.2.0
Assigned To: Stuart Douglas
Jan Martiska
Russell Dickenson
:
Depends On: 1024984
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 13:19 EDT by Stuart Douglas
Modified: 2013-12-15 11:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker EJBCLIENT-97 Major Resolved DataOutputStream calls flush() before close which decreases performance 2014-06-17 16:27:17 EDT

  None (edit)
Description Stuart Douglas 2013-10-30 13:19:19 EDT
Description of problem:

Because DataOutputStream does a flush() before close EJB invocations are send via two separate write() calls, rather than one, which has a negative impact on performance.
Comment 4 Jan Martiska 2013-11-11 09:47:01 EST
Verified in CR1.

Note You need to log in before you can comment on or make changes to this bug.