Bug 1024990 - [DWH] ETL process doesn't recover from postgres restart
[DWH] ETL process doesn't recover from postgres restart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Yaniv Lavi
Barak Dagan
infra
: Triaged
: 1034272 (view as bug list)
Depends On: 1028216
Blocks: 3.3snap3
  Show dependency treegraph
 
Reported: 2013-10-30 13:27 EDT by Barak Dagan
Modified: 2016-02-10 14:09 EST (History)
10 users (show)

See Also:
Fixed In Version: IS25 - rhevm-dwh-3.3.0-23.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:01:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dwh log (1.54 KB, application/x-tar-gz)
2013-10-30 13:27 EDT, Barak Dagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21634 None None None Never
oVirt gerrit 21698 None None None Never

  None (edit)
Description Barak Dagan 2013-10-30 13:27:29 EDT
Created attachment 817543 [details]
dwh log

Description of problem:
During reports installation, the engine shuts down and restart when installation is over. ETL process continue to flood the log with connectivity issues, untill it is manually restarted

Version-Release number of selected component (if applicable):
is20.1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Lavi 2013-10-31 09:39:45 EDT
Please recreate using SI21


Yaniv
Comment 2 Yaniv Lavi 2013-11-06 11:02:59 EST
Martin, DWH Heartbeat seems to stop working after restart of postgres. Do tou have a clue to why this is?



Yaniv
Comment 3 Martin Perina 2013-11-08 10:36:49 EST
It's not a problem of DWH HeartBeat, but it's probably a bug in JBoss EAP 6.1+.
DWH Heartbeat works properly on oVirt master using JBoss 7.1.1
Comment 6 Juan Hernández 2013-11-25 08:34:06 EST
According to the JBoss team adding <validate-on-match>true</validate-on-match> to the data source definition should fix the issue with reconnecting to the database.

http://gerrit.ovirt.org/21634

Please check.
Comment 7 Yaniv Lavi 2013-11-25 09:24:35 EST
*** Bug 1034272 has been marked as a duplicate of this bug. ***
Comment 8 Barak Dagan 2013-11-25 09:36:06 EST
As cam be seen in https://bugzilla.redhat.com/show_bug.cgi?id=1034272. it continues
Comment 9 Martin Perina 2013-11-26 04:49:21 EST
(In reply to Barak Dagan from comment #8)
> As cam be seen in https://bugzilla.redhat.com/show_bug.cgi?id=1034272. it
> continues
Barak, did you apply the patch before testing?

I tried this today on is24.2 with patch applied and ovirt-engine now works correctly after db is started again. So IMHO the patch should solve the issue ...
Comment 11 Charlie 2013-11-27 19:54:08 EST
This bug is currently attached to errata RHEA-2013:15116. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 Barak Dagan 2013-12-11 07:42:28 EST
Verified on IS26, rhevm-dwh-3.3.0-24.el6ev.noarch.

dwh doesn't log connectivity errors when engine or db services are down for a short time (few minutes)
Comment 14 errata-xmlrpc 2014-01-21 10:01:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0036.html

Note You need to log in before you can comment on or make changes to this bug.