Bug 1025000 - Windows 2008 Server as VM in RHEV-M 3.3 loads the HDA sound card and it needs the AC'97 instead.
Windows 2008 Server as VM in RHEV-M 3.3 loads the HDA sound card and it needs...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Roy Golan
Pavel Novotny
virt
:
Depends On:
Blocks: 3.3snap3
  Show dependency treegraph
 
Reported: 2013-10-30 13:56 EDT by Bill Sanford
Modified: 2014-01-21 17:12 EST (History)
13 users (show)

See Also:
Fixed In Version: is25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21210 None None None Never
oVirt gerrit 21422 None None None Never

  None (edit)
Description Bill Sanford 2013-10-30 13:56:25 EDT
Description of problem:
Windows 2008 Server (Not the R2 version) as a VM in RHEV-M 3.3 (is19),the soundcard (When enabled) is the Intel HDA card. The command-line qemu has "-device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0" as the driver.

No sound hardware is seen in the VM.

I then shutdown the VM and switch the OS to XP (To load the AC'97 drivers) and the sound in the Windows 2008 Server OS, works.


Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is19) - RHEV-M client.
Windows 2008 server - RHEV-M guest

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

qemu command line on host with Windows 2008 Server in VM configuration:

qemu      6927  6.4 27.4 2637652 2240316 ?     Sl   Oct29  95:03 /usr/libexec/qemu-kvm -name W2k8Server -S -M rhel6.5.0 -cpu Opteron_G3 -enable-kvm -m 2048 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 6ca477dd-7c9b-4e14-834c-f8aa82a6a344 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.5.0.0.el6,serial=8AA6FB90-56CB-1020-0519-153434000000,uuid=6ca477dd-7c9b-4e14-834c-f8aa82a6a344 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/W2k8Server.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2013-10-29T16:58:30,driftfix=slew -no-shutdown -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x6 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/rhev/data-center/mnt/blockSD/3bf77a26-3a5a-4d29-8952-31e98dcc4753/images/9541bfe4-6cc4-4b6a-9585-becd32c28c1f/6385f345-3389-4927-b83a-1a82ca1fc24f,if=none,id=drive-ide0-0-0,format=raw,serial=9541bfe4-6cc4-4b6a-9585-becd32c28c1f,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/rhev/data-center/mnt/10.19.168.10:_rhev_isos/e1a50b62-693a-412c-bffd-2c9147e4c5b4/images/11111111-1111-1111-1111-111111111111/en_windows_server_2008_with_sp2_x86_dvd_342333.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0,bootindex=2 -netdev tap,fd=29,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:1a:4a:dc:ca:01,bus=pci.0,addr=0x3,bootindex=3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/6ca477dd-7c9b-4e14-834c-f8aa82a6a344.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/6ca477dd-7c9b-4e14-834c-f8aa82a6a344.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=5900,tls-port=5903,addr=0,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8
Comment 1 Michal Skrivanek 2013-11-07 10:28:04 EST
should be simple fix. In OSInfo either override devices.audio.value to ac97 or inherit 2008R2 from W2003, but since the sysprep is the same, I'd just override again the audio device
Comment 2 Roy Golan 2013-11-13 06:01:18 EST
Windows 2008 will be changed to ac97
Windows 2008 R2 left unchanged
what about 2008 64 bit?
Comment 3 Bill Sanford 2013-11-19 11:07:55 EST
Roy, that should stay as the Intel HDMA. That is working fine.
Comment 4 Bill Sanford 2013-11-19 11:09:34 EST
Roy, that would be regarding the W2K8R2 setting.
Comment 5 Michal Skrivanek 2013-11-20 07:02:25 EST
so it's going to be
ac97: 2008 32bit
ich6: 2008 64bit, 2008R2 64bit
Comment 6 Pavel Novotny 2013-11-28 08:05:49 EST
Verified in rhevm-3.3.0-0.37.beta1.el6ev.noarch (is25).

All Windows 2008 VMs are running with correct soundcard types assigned:
Win 2008 32b: AC97
Win 2008 64b & 2008 R2 64b: Intel HDA

QEMU commands then look like:
Windows 2008 (32b):
-device AC97,id=sound0,bus=pci.0,addr=0x3
Windows 2008 x64:
-device intel-hda,id=sound0,bus=pci.0,addr=0x3 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0
Windows 2008 R2 x64:
-device intel-hda,id=sound0,bus=pci.0,addr=0x3 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0
Comment 7 Itamar Heim 2014-01-21 17:12:05 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.