Bug 1025004 - Update from F19 to F20 fails due to perl version dependencies
Update from F19 to F20 fails due to perl version dependencies
Status: CLOSED DUPLICATE of bug 992666
Product: Fedora
Classification: Fedora
Component: perl-Language-Expr (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-10-30 14:00 EDT by Michael Wiktowy
Modified: 2013-10-30 17:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-30 17:29:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Wiktowy 2013-10-30 14:00:49 EDT
Description of problem:
On an updated F19 system, running the following yum update command line:

yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates distro-sync

causes the following error for perl-Language-Expr:

Error: Package: perl-Language-Expr-0.19-4.fc19.noarch (@fedora/19)
           Requires: perl(:MODULE_COMPAT_5.16.2)
           Removing: 4:perl-5.16.3-265.fc19.x86_64 (installed)
           Updated By: 4:perl-5.18.1-288.fc20.x86_64 (fedora)

Additional info:
This is a test requested as per:


in order to uncover F19->F20 packaging/dependency issues.
Comment 1 Paul Howarth 2013-10-30 17:29:01 EDT
Known issue, not likely to be fixed until perl 5.18.2 comes out.

*** This bug has been marked as a duplicate of bug 992666 ***

Note You need to log in before you can comment on or make changes to this bug.