Bug 1025006 - Add support for S1 suspend state
Summary: Add support for S1 suspend state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pm-utils
Version: 6.6
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 994246 1005342 1094293
TreeView+ depends on / blocked
 
Reported: 2013-10-30 18:05 UTC by Eduardo Minguez
Modified: 2019-03-22 07:08 UTC (History)
11 users (show)

Fixed In Version: pm-utils-1.2.5-11.el6
Doc Type: Bug Fix
Doc Text:
Previously, pm-utils did not support the Advanced Configuration and Power Interfaces (ACPI) S1 (Power on Suspend) power state. As a consequence, when BIOS supported the ACPI S3 (Suspend to RAM) power state but not the S1 power state, the "pm-suspend" command failed. This update introduces support for the S1 power state, and if the S3 power state is not supported by BIOS, pm-suspend now triggers the S1 power state.
Clone Of:
Environment:
Last Closed: 2014-10-14 06:33:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed fix (542 bytes, patch)
2014-05-05 11:40 UTC, Jaroslav Škarvada
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1455 normal SHIPPED_LIVE pm-utils bug fix update 2014-10-14 01:05:34 UTC

Description Eduardo Minguez 2013-10-30 18:05:31 UTC
Description of problem:
Trying to suspend by running "pm-suspend" to S1 acpi state (standby) doesn't work

Version-Release number of selected component (if applicable):
pm-utils-1.2.5-10

How reproducible:
Configure the BIOS for suspend only to S1 state and run pm-suspend

Steps to Reproduce:
1. Configure BIOS settings to allow acpi suspension only to S1 state
2. Execute pm-suspend

Actual results:
pm-suspend exits (code error 0) but the computer is not suspended

Expected results:
pm-suspend works by changing the acpi state to S1

Additional info:
I've seen in /usr/lib/pm-utils/pm-functions that changing the following works:

    # diff pm-functions pm-functions.old 
    257c257
    < 	if grep -q standby /sys/power/state; then
    ---
    > 	if grep -q mem /sys/power/state; then
    259c259
    < 		do_suspend() { echo -n "standby" >/sys/power/state; }
    ---
    > 		do_suspend() { echo -n "mem" >/sys/power/state; }

Sorry for the ugly workaround!

Comment 7 Jaroslav Škarvada 2014-05-05 11:40:53 UTC
Created attachment 892496 [details]
Proposed fix

Using standby as workaround.

Comment 13 errata-xmlrpc 2014-10-14 06:33:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1455.html


Note You need to log in before you can comment on or make changes to this bug.