Bug 1025008 - BIND 9.8 configured with --enable-ipv6 but not with --enable-filter-aaaa
BIND 9.8 configured with --enable-ipv6 but not with --enable-filter-aaaa
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
: Patch
: 1036563 (view as bug list)
Depends On:
Blocks: 1056252 1070830
  Show dependency treegraph
 
Reported: 2013-10-30 14:05 EDT by Eric Wolfe
Modified: 2016-04-21 17:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: bind-9.8.2-0.25.rc1.el6
Doc Type: Bug Fix
Doc Text:
Cause: BIND was not previously configured with the --enable-filter-aaaa option before build. Consequence: As a consequence the filter-aaaa-on-v4 option could not be used in the BIND configuration. Fix: The --enable-filter-aaaa configure option has been added so BIND is configured properly before build. Result: Users can now use the filter-aaaa-on-v4 option in the BIND configuration.
Story Points: ---
Clone Of:
: 1025245 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:35:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bind.spec.patch (308 bytes, patch)
2013-10-30 14:09 EDT, Eric Wolfe
no flags Details | Diff

  None (edit)
Description Eric Wolfe 2013-10-30 14:05:47 EDT
Description of problem:

Newer versions of BIND (>= 9.7.1) have the option to filter AAAA (ipv6) records for ipv4-only clients.

Version-Release number of selected component (if applicable):

9.8.2-0.17.rc1

Steps to Reproduce:
1.  Add `filter-aaaa-on-v4` to named options.
2.  Run `service named reload`
3.  Watch for error in messages log.

Actual results:

Error from messages log:

option 'filter-aaaa-on-v4' is not configured

Expected results:

If bind-9.8 is compiled with configure option `--enable-ipv6`, then `--enable-filter-aaaa` should also be a configure option.  This should help in dual-stack environments where some clients are ipv4-only, and both A and AAAA records exist for a given hostname.

Additional info:

Suggested fix:  Add `--enable-filter-aaaa` to configure options in bind.spec
Comment 1 Eric Wolfe 2013-10-30 14:09:28 EDT
Created attachment 817562 [details]
bind.spec.patch

proposed configure option attached in patch
Comment 3 Tomáš Hozza 2013-10-31 06:01:59 EDT
(In reply to Eric Wolfe from comment #0)
> If bind-9.8 is compiled with configure option `--enable-ipv6`, then
> `--enable-filter-aaaa` should also be a configure option.

Not necessarily. filter-aaaa-on-v4 should be used only when really necessary,
since it can cause some problems. But I agree that we should enable the choice
to users.
Comment 4 Eric Wolfe 2013-11-01 10:49:00 EDT
Tomas, yes, I understand it may not be appropriate in all cases.

I really just want the ability to test this in our environment, using the package as shipped with RHEL.
Comment 5 Tomáš Hozza 2013-12-02 05:04:59 EST
*** Bug 1036563 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2014-10-14 00:35:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1373.html

Note You need to log in before you can comment on or make changes to this bug.