Bug 1025019 - Cluster 'Comment' field should be updated when new hosts found in the cluster
Cluster 'Comment' field should be updated when new hosts found in the cluster
Status: CLOSED CANTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Kanagaraj
RHS-C QE
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 14:23 EDT by Kanagaraj
Modified: 2016-04-18 06:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-27 07:53:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20755 master ABANDONED gluster: update cluster 'comment' when new host found Never

  None (edit)
Description Kanagaraj 2013-10-30 14:23:57 EDT
Description of problem:

When there are new hosts added using 'gluster cli' to an existing cluster, currently there is no way the user will get notified. Cluster 'comment' should updated with proper notification messages saying there new hosts which are available for import. So that the user will get to know the there are some new hosts when looking at the clusters list.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a cluster with 2 hosts
2. peer probe host3 from any of the above 2 hosts
3. Observe the Clusters tab

Actual results:
The user has to select the cluster and look over 'General' sub tab to know there are some new hosts found in the cluster.

Expected results:
'Comment' field of the cluster should updated with message 'ACTION REQUIRED: Some new hosts found in the cluster'. On selecting the cluster, 'General' sub-tab should provide actions to import or detach the newly discovered hosts.

Additional info:
Comment 2 Dusmant 2013-12-09 00:56:38 EST
Comment field is going to be updated/removed in the upstream and it does not look like, we can use this field. So, nothing can be done on this bug.

We need to take it out of Corbett.
Comment 3 Kanagaraj 2014-05-22 00:01:58 EDT
The approach of updating the comment field doesn't look good. We need to think of a different approach.
Comment 4 Sahina Bose 2015-03-27 07:53:40 EDT
Since comments field is not the right place to show this information, closing this. There is a bug open to have a better indication when a host is detected - bug 910698

Note You need to log in before you can comment on or make changes to this bug.