Bug 1025044 - [GUI] Filtering non-stackable subscriptions based on cores does not consider number of Sockets
[GUI] Filtering non-stackable subscriptions based on cores does not consider ...
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
Katello QA List
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-30 16:05 EDT by Sharath Dwaral
Modified: 2015-05-14 12:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-29 15:05:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2013-10-30 16:05:29 EDT
Description of problem:
Filtering non-stackable subscriptions based on cores does not consider number of Sockets

Version-Release number of selected component (if applicable):
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.9.11-1.el6
python-rhsm: 1.9.6-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Increase Cores to 26 (cpu.core(s)_per_socket = 26) 
   and sockets is 2 (cpu.cpu_socket(s) = 2)
2. Goto All-Available-Subscriptions window
3. Check all filters and click update
4. You can see "Cores Package (26 cores)" which is a 
   non-stackable subscription

Actual results:
This should not be displayed because present system cores = 26*2 = 52 which is not covered by non-stackable subscription "Cores Package (26 cores)"

Expected results:
"Cores Package (26 cores)" should no be displayed as it is non-stackable and does not match-the-system

Additional info:
Comment 1 Carter Kozak 2013-11-01 08:26:55 EDT
commit c907ece127cd42d24d702329145c55f22ac1ff7e
Author: ckozak <ckozak@redhat.com>
Date:   Wed Oct 30 16:07:05 2013 -0400

    1025044: fix cores pre-entitlement calculation
    
    cores pre_entitlement check was not properly multiplying
    cores_per_cpu by sockets. This caused us not to filter
    some subscriptions from list available that we should.
    
    Added tests for other pre_entitlement attribute warnings
    as well
Comment 2 Sharath Dwaral 2014-02-03 15:38:11 EST
Version

# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription-manager: 1.10.11-2.el7
python-rhsm: 1.10.11-2.el7


Verification:

# cat /etc/rhsm/facts/override.facts 
{"cpu.core(s)_per_socket":"26",
"cpu.cpu_socket(s)":"2",
"virt.is_guest": "False"}

# subscription-manager facts --list | egrep "^virt|^cpu"
cpu.core(s)_per_socket: 26                           <<<<<<<<<<
cpu.cpu(s): 2
cpu.cpu_socket(s): 2                                 <<<<<<<<<<
cpu.thread(s)_per_core: 1
cpu.topology_source: kernel /sys cpu sibling lists
virt.host_type: kvm
virt.is_guest: False                                 <<<<<<<<<<
virt.uuid: eb692370-e61d-110c-2d6c-2e59ad47092b


After the system is made physical (virt.is_guest: False) "Cores Package (26 cores)" subscription is no displayed as it is not stackable.

VERIFIED
Comment 4 Bryan Kearney 2014-09-29 15:05:35 EDT
These bugs were fixed during 7.0 but not moved to CLOSED. They have been delivered

Note You need to log in before you can comment on or make changes to this bug.