This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025054 - Need ability to create uidgid entries for corosync in cluster.conf using pcs
Need ability to create uidgid entries for corosync in cluster.conf using pcs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Chris Feist
: Reopened, ZStream
Depends On: 896628
Blocks: 1038476 1038478
  Show dependency treegraph
 
Reported: 2013-10-30 17:08 EDT by Chris Feist
Modified: 2014-10-14 03:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: pcs-0.9.101-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, pcs was unable to create user ID (UID) and group ID (GID) entries in the cluster.conf file. Because of this, non-root users could not gain access to the corosync.conf file and therefore could not access corosync. With this update, pcs support for configuring UID and GID entries in cluster.conf has been added, and non-root users can now be granted access to corosync with the "pcs cluster uidgid" command.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:21:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2013-10-30 17:08:12 EDT
Need ability to create uidgid entries for corosync in cluster.conf using pcs
Comment 1 Fabio Massimo Di Nitto 2013-11-20 04:52:14 EST
Bumping, we need this for RHOS use case.
Comment 2 Chris Feist 2013-12-04 19:17:27 EST
Before Fix:

[root@ask-02 test]# rpm -q pcs
pcs-0.9.90-2.el6.noarch
[root@ask-02 test]# pcs cluster uidgid

... prints usage information ...


After Fix:
[root@ask-02 test]# rpm -q pcs
pcs-0.9.101-1.el6.noarch
[root@ask-02 test]# pcs cluster uidgid add uid=feist gid=feist
[root@ask-02 test]# cat /etc/cluster/cluster.conf | grep uidgid
  <uidgid gid="feist" uid="feist"/>
[root@ask-02 test]# pcs cluster uidgid rm uid=feist gid=feist
[root@ask-02 test]# cat /etc/cluster/cluster.conf | grep uidgid
[root@ask-02 test]#
Comment 10 errata-xmlrpc 2014-10-14 03:21:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1526.html

Note You need to log in before you can comment on or make changes to this bug.