Bug 1025062 - scala can't be installed on F20 due to missing dependency on jansi.jar
scala can't be installed on F20 due to missing dependency on jansi.jar
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scala (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Geoff Reedy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 18:03 EDT by igor.redhat@gmail.com
Modified: 2013-11-10 01:07 EST (History)
2 users (show)

See Also:
Fixed In Version: scala-2.10.3-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:07:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description igor.redhat@gmail.com 2013-10-30 18:03:11 EDT
Description of problem:

$ sudo yum install scala scala-examples
Loaded plugins: auto-update-debuginfo, etckeeper, fastestmirror, langpacks, refresh-packagekit,
              : verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.mit.edu
 * rpmfusion-free-rawhide: mirror.nexcess.net
 * rpmfusion-nonfree-rawhide: mirror.nexcess.net
 * updates: mirrors.mit.edu
 * updates-testing: mirrors.mit.edu
Resolving Dependencies
--> Running transaction check
---> Package scala.noarch 0:2.10.3-2.fc20 will be installed
--> Processing Dependency: /usr/share/java/jansi.jar for package: scala-2.10.3-2.fc20.noarch
---> Package scala-examples.noarch 0:2.10.3-2.fc20 will be installed
--> Processing Dependency: /usr/share/java/jansi.jar for package: scala-2.10.3-2.fc20.noarch
--> Finished Dependency Resolution
Error: Package: scala-2.10.3-2.fc20.noarch (updates-testing)
           Requires: /usr/share/java/jansi.jar
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Not that jansi is available and installed but as /usr/share/java/jansi/jansi.jar

Version-Release number of selected component (if applicable):

2.10.3-2.fc20

How reproducible:

Always

Steps to Reproduce:

yum install scala

Additional Info:

Also see bug 1021465
Comment 1 Fedora Update System 2013-10-31 06:08:03 EDT
scala-2.10.3-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scala-2.10.3-6.fc20
Comment 2 Fedora Update System 2013-10-31 13:38:50 EDT
Package scala-2.10.3-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scala-2.10.3-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20384/scala-2.10.3-6.fc20
then log in and leave karma (feedback).
Comment 3 igor.redhat@gmail.com 2013-10-31 20:30:09 EDT
That helped as far as jansi.jar is concerned but scala still cannot be installed due to unsatisfied dependency on jline:

$ sudo yum install --enablerepo=updates-testing scala scala-examples
[sudo] password for igor: 
Loaded plugins: auto-update-debuginfo, etckeeper, fastestmirror, langpacks, refresh-packagekit,
              : verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.mit.edu
 * rpmfusion-free-rawhide: mirror.nexcess.net
 * rpmfusion-nonfree-rawhide: mirror.nexcess.net
 * updates: mirrors.mit.edu
 * updates-testing: mirrors.mit.edu
Resolving Dependencies
--> Running transaction check
---> Package scala.noarch 0:2.10.3-6.fc20 will be installed
--> Processing Dependency: jline >= 2.10 for package: scala-2.10.3-6.fc20.noarch
---> Package scala-examples.noarch 0:2.10.3-6.fc20 will be installed
--> Finished Dependency Resolution
Error: Package: scala-2.10.3-6.fc20.noarch (updates-testing)
           Requires: jline >= 2.10
           Installed: jline-1.0-5.fc20.noarch (installed)
               jline = 1.0-5.fc20
 You could try using --skip-broken to work around the problem

1.0.5 is the latest jline available in the repos; is it supposed to depend on jline2 (2.10.8 in the repo)?
Comment 4 Jochen Schmitt 2013-11-01 04:55:00 EDT
I know, that scala-2.10.3-6.fc20 has an error. So it may be nice, if you can
try out scala-2.10.3-7.fc20.
Comment 5 Fedora Update System 2013-11-01 16:25:31 EDT
Package scala-2.10.3-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scala-2.10.3-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20384/scala-2.10.3-7.fc20
then log in and leave karma (feedback).
Comment 6 igor.redhat@gmail.com 2013-11-02 12:36:43 EDT
Thanks, 2.10.3-7 installs fine.
Comment 7 Fedora Update System 2013-11-10 01:07:17 EST
scala-2.10.3-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.