Bug 1025065 - Authconfig does not specify args for pam_mkhomedir which results in umask=0022 and world-readable home directories.
Summary: Authconfig does not specify args for pam_mkhomedir which results in umask=002...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-30 22:40 UTC by John Conroy
Modified: 2015-03-02 05:28 UTC (History)
4 users (show)

Fixed In Version: authconfig-6.1.12-14.el6
Doc Type: Bug Fix
Doc Text:
Cause: The default umask when creating home directories with pam_mkhomedir is 0022. Consequence: The home directories created with pam_mkhomedir were world readable. Fix: Use umask=0077 option with pam_mkhomedir by default. Result: The home directories newly created by pam_mkhomedir are no longer world readable.
Clone Of:
Environment:
Last Closed: 2014-10-14 07:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1558 normal SHIPPED_LIVE authconfig bug fix and enhancement update 2014-10-14 01:27:53 UTC

Description John Conroy 2013-10-30 22:40:33 UTC
Description of problem:
By default, authconfig does not specify args for pam_mkhomedir (or pam_oddjob_mkhomedir) which results in umask=0022 and world-readable home directories.

Version-Release number of selected component (if applicable):
authconfig-6.1.12-13.el6

How reproducible:
Always

Steps to Reproduce:
1.  authconfig --enablemkhomedir --updateall
2.  Check the PAM config files in /etc/pam.d
3.

Actual results:
No arguments are supplied, resulting in a UMASK of 0022 for home directories making them world-readable by default.

Expected results:
Something along the lines of "skel=/etc/skel/ umask=0077", though skel is supposed to be defaulted to /etc/skel and should be unecessary.

Additional info:
Should probably update authinfo.py to supply a more sane default UMASK to the pam_mkhomedir plugin or allow the args to be specified on the command line and saved in /etc/sysconfig/authconfig...or both.  :)

self.mkhomedirArgs = "skel=/etc/skel/ umask=0077"

Comment 3 Tomas Mraz 2014-03-26 09:51:29 UTC
We would just add umask=0077 to the initial arguments of pam_mkhomedir/pam_oddjob_mkhomedir if enabled with --enablemkhomedir.

Comment 7 errata-xmlrpc 2014-10-14 07:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1558.html


Note You need to log in before you can comment on or make changes to this bug.