Bug 1025066 - Fedora 20 upgrade fails on xine-extras
Fedora 20 upgrade fails on xine-extras
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 18:40 EDT by DBV
Modified: 2013-10-31 03:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 03:37:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DBV 2013-10-30 18:40:35 EDT
Description of problem:
Following the instructions found on PlanetFedora (1-minute test) to test upgrading from F19 to F20 revealed an issue on xine-extras

Version-Release number of selected component (if applicable):
See "actual results" section.

How reproducible:
All the time


Steps to Reproduce:
sudo yum --releasever=20 --enablerepo=updates-testing --enablerepo=updates --disablerepo=Dropbox --disablerepo=rpmfusion-free-updates --disablerepo=rpmfusion-free --disablerepo=rpmfusion-nonfree-updates --disablerepo=rpmfusion-nonfree distro-sync

Actual results:
[...]
--> Finished Dependency Resolution
Error: Package: xine-lib-extras-1.1.21-5.fc19.x86_64 (installed)
           Requires: libMagickWand.so.5()(64bit)
           Removing: ImageMagick-6.7.8.9-5.fc19.x86_64 (installed)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.8.6.3-3.fc20.x86_64 (fedora)
               Not found
Error: Package: xine-lib-extras-1.1.21-5.fc19.x86_64 (installed)
           Requires: libMagickCore.so.5()(64bit)
           Removing: ImageMagick-6.7.8.9-5.fc19.x86_64 (installed)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.8.6.3-3.fc20.x86_64 (fedora)
               Not found


Expected results:
The prompt to accepts the installation ([Y/n]) should be reached.
Comment 1 Jan Zeleny 2013-10-31 03:37:47 EDT
Not a bug in yum, the problem is in dependency chain, probably some discontinued packages between Fedora versions. Note that doing the dist upgrade this way is not supported exactly because problems like this one. In this particular case I recommend uninstalling the problematic packages (xine-lib-magic) and then running the update.

Note You need to log in before you can comment on or make changes to this bug.