Bug 1025112 - zanata-cli: Incorrect BASE_JARS
zanata-cli: Incorrect BASE_JARS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: zanata-client (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
:
: 1004136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 23:21 EDT by Ding-Yi Chen
Modified: 2014-03-25 20:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: zanata-client-2.2.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-09 21:58:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-10-30 23:21:38 EDT
Description of problem:
zanata-cli cannot run with Incorrect BASE_JARS.

Currect: 

BASE_JARS="zanata-rest-client zanata-client-commands zanata-cli slf4j/log4j12 opencsv"

Correct:
BASE_JARS="zanata-client/zanata-rest-client zanata-client/zanata-client-commands zanata-client/zanata-cli slf4j/log4j12 opencsv"

Version-Release number of selected component (if applicable):
2.2.0

How reproducible:
Always

Steps to Reproduce:
1. Run "zanata-cli"

Actual results:
/usr/bin/build-classpath: error: Could not find zanata-rest-client Java extension for this JVM
/usr/bin/build-classpath: error: Could not find zanata-client-commands Java extension for this JVM
/usr/bin/build-classpath: error: Could not find zanata-cli Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Error: Could not find or load main class org.zanata.client.ZanataClient



Expected results:
Show a brief usage page.

Additional info:
Comment 1 Ding-Yi Chen 2014-03-25 19:51:13 EDT
*** Bug 1004136 has been marked as a duplicate of this bug. ***
Comment 2 Sean Flanigan 2014-03-25 20:16:27 EDT
What does CLOSED(NEXTRELEASE) mean for zanata-cli?  I don't think we should use NEXTRELEASE for Zanata.  Or should this bug be reassigned to the Fedora project?

Even if it is a bug in the Fedora package for zanata-cli, we should really fix a bug like this one in fedora-updates, not just the next release.
Comment 3 Sean Flanigan 2014-03-25 20:16:59 EDT
Also, which version actually has the fix?
Comment 4 Ding-Yi Chen 2014-03-25 20:58:11 EDT
For fedora releases, it is recommend to use bodhi and fill the bug number.
After the fix been pushed as stable, it would automatically close the bug and fill in Fix in number.

This was fixed in zanata-client-2.2.0-3.fc19 and zanata-client-2.2.0-3.fc18

Note You need to log in before you can comment on or make changes to this bug.