Bug 1025163 - quota: list command fails with "Error on quota auxiliary mount"
quota: list command fails with "Error on quota auxiliary mount"
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Saurabh
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 02:52 EDT by Saurabh
Modified: 2016-01-19 01:13 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.38rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:44:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-10-31 02:52:27 EDT
Description of problem:

I was already having a volume with quota enabled and limit set on it.
I updated my cluster to gluster-3.4.0.37rhs from gluster-3.4.0.36rhs
Now, if i execute the command gluster volume quota $volname list
it results in a failure,

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.37rhs

How reproducible:
happend already on two set of clusters


Actual results:
[root@quota5 ~]# gluster volume quota dist-rep list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          2.9TB       80%       2.2TB 745.6GB
/qa1                                     512.0GB       80%     512.0GB  23.1MB
/qa2                                     512.0GB       80%     512.0GB  0Bytes
/qa3                                     100.0GB       80%     100.0GB  0Bytes
/qa4                                     100.0GB       80%     100.0GB  0Bytes
/qa1/dir1                                500.0GB       80%     412.0GB  88.0GB
/qa2/dir1                                500.0GB       80%     412.0GB  88.0GB
/qa5                                     500.0GB       80%     500.0GB  0Bytes
/qa6                                     500.0GB       80%     500.0GB  0Bytes


yum update (from updating glusterfs rpm from 3.4.0.36rhs to 3.4.0.37rhs)

gluster volume start
[root@quota5 ~]# gluster volume start dist-rep
volume start: dist-rep: success

[root@quota5 ~]# gluster volume quota dist-rep list
quota: Error on quota auxiliary mount (No such file or directory).

[root@quota5 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_quota5-lv_root
                       42G  3.9G   36G  10% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   32M  428M   7% /boot
/dev/mapper/RHS_vgvdb-RHS_lv1
                      1.5T  1.3T  241G  85% /rhs/brick1
localhost:dist-rep    4.4T  3.5T  987G  78% /tmp/dist-rep


Expected results:
come on, the quota list has worked after yum update from glusterfs-3.4.0.34rhs  to glusterfs-3.4.0.35.rhs to glusterfs-3.4.0.36rhs
so, should work on glusterfs-3.4.0.36rhs to glusterfs-3.4.0.37rhs

Additional info:
Comment 2 Pranith Kumar K 2013-10-31 03:22:58 EDT
Both kritika and I worked on this bug in parallel.
I found that the problem is happening because of the following reason:
the aux mount is supposed to be created at "/var/run/gluster/<volname>"
Since that directory is not present yet, it is giving this error.
If I create the directory, the error goes away.
[root@server3 glusterfs]# mkdir /var/run/gluster/shanks-quota
[root@server3 glusterfs]# gluster volume quota shanks-quota list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                         70.0GB       80%      0Bytes  70.0GB

If I delete the directory the error comes back:
[root@server3 glusterfs]# rmdir /var/run/gluster/shanks-quota
[root@server3 glusterfs]# gluster volume quota shanks-quota list
quota: Error on quota auxiliary mount (No such file or directory).

Kritika found the reason in the code and will be posting the patch.

We need that directory created at /var/run/gluster/<volname> for the "quota list" to work properly. Kritika suggests that we use "gluster volume quota <volname> list <path>" to do the same.
Comment 3 Gowrishankar Rajaiyan 2013-10-31 04:05:43 EDT
IMHO list should not be creating any directories in the back-end, rather limit-usage should since you would set limit-usage after enabling quota. list will fail if executed in between enabling quota and setting limit-usage, which would be expected.

my two cents,
- shanks
Comment 5 Saurabh 2013-10-31 04:54:44 EDT
on same node as mentioned in description section, this command has also failed.

[root@quota5 ~]# gluster volume quota dist-rep list /
quota: Error on quota auxiliary mount (No such file or directory).

[root@quota5 ~]# gluster volume quota dist-rep list /qa1
quota: Error on quota auxiliary mount (No such file or directory).
Comment 7 Krutika Dhananjay 2013-10-31 05:57:55 EDT
Typo in comment #6.

Please read glusterfs-3.4.0.36rhs as glusterfs-3.4.0.37rhs in comment #6.
Comment 8 Gowrishankar Rajaiyan 2013-11-01 07:01:16 EDT
[root@server1 ~]# gluster vol quota shanks-quota list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        100.0GB       80%      0Bytes 100.0GB
[root@server1 ~]# gluster vol quota shanks-quota2 list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0GB       80%      0Bytes 200.0GB
[root@server1 ~]# 





[root@server3 ~]# gluster vol quota shanks-quota list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        100.0GB       80%      0Bytes 100.0GB
[root@server3 ~]# gluster vol quota shanks-quota2 list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0GB       80%      0Bytes 200.0GB
[root@server3 ~]# gluster vol quota shanks-quota2 list /
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0GB       80%      0Bytes 200.0GB
[root@server3 ~]# gluster vol quota shanks-quota2 list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0GB       80%      0Bytes 200.0GB
[root@server3 ~]# 



[root@server1 ~]# gluster vol quota shanks-quota2 limit-usage /test1 50GB
volume quota : success
[root@server1 ~]# gluster vol quota shanks-quota2 list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0GB       80%      0Bytes 200.0GB
/test1                                    50.0GB       80%      0Bytes  50.0GB
[root@server1 ~]# gluster vol quota shanks-quota2 list //test1
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/test1                                    50.0GB       80%      0Bytes  50.0GB
[root@server1 ~]# gluster vol quota shanks-quota2 list /test1
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/test1                                    50.0GB       80%      0Bytes  50.0GB
[root@server1 ~]# 


Verified. glusterfs-server-3.4.0.38rhs-1.el6rhs.x86_64
Comment 13 errata-xmlrpc 2013-11-27 10:44:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.