This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025189 - daily log rotate is not enough when engine log files are flooded with messages (debug mode)
daily log rotate is not enough when engine log files are flooded with message...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 04:14 EDT by Ilanit Stein
Modified: 2013-11-10 06:51 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 02:55:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine_log (5.68 MB, application/x-gzip)
2013-10-31 04:23 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2013-10-31 04:14:39 EDT
Description of problem:

The daily log rotate is not enough, for example  when configuring debug mode,  and in parallel messages flood the log.

On a setup with little space, after log was filled, and caused 100% of disk space,
Postgresql service crashed (DB connection lost).

Please consider some alternative mechanism for log rotate, in which log size    
is also taken under consideration.

Version-Release number of selected component (if applicable):
is20.1
Comment 1 Ilanit Stein 2013-10-31 04:23:49 EDT
Created attachment 817748 [details]
engine_log
Comment 2 Ilanit Stein 2013-10-31 04:51:39 EDT
ls -ltrh
total 850M
drwxr-xr-x. 2 root  root  4.0K Sep  5 22:27 ovirt-image-uploader
drwxr-xr-x. 2 root  root  4.0K Sep  7 17:09 ovirt-log-collector
drwxr-xr-x. 2 ovirt ovirt 4.0K Oct 24 16:51 notifier
drwxr-xr-x  2 ovirt ovirt 4.0K Oct 24 16:51 dump
drwxr-xr-x. 2 root  root  4.0K Oct 28 11:08 ovirt-iso-uploader
drwxr-xr-x. 2 root  root  4.0K Oct 30 12:17 setup
drwxr-xr-x. 2 ovirt ovirt 4.0K Oct 30 13:00 host-deploy
-rw-r--r--  1 root  root  6.8K Oct 30 13:04 engine-manage-domains.log
-rw-r--r--. 1 root  root  540K Oct 30 13:04 engine-config.log
-rw-r--r--. 1 ovirt ovirt    0 Oct 31 09:26 console.log
-rw-r--r--. 1 ovirt ovirt  875 Oct 31 09:26 boot.log
-rw-r--r--. 1 ovirt ovirt 247K Oct 31 09:26 redhat-support-plugin-rhev.log
-rw-r--r--. 1 ovirt ovirt 136M Oct 31 10:44 engine.log
-rw-r--r--. 1 ovirt ovirt 662M Oct 31 10:44 server.log
Comment 3 Alon Bar-Lev 2013-11-04 02:51:32 EST
Administrator is more than welcome to set logrotate service at higher interval.
Comment 4 Sandro Bonazzola 2013-11-06 02:55:51 EST
(In reply to Alon Bar-Lev from comment #3)
> Administrator is more than welcome to set logrotate service at higher
> interval.

Closing as not a bug as per comment #3.
Comment 5 Yedidyah Bar David 2013-11-10 01:40:16 EST
See also the discussion in bug #948481 which triggered the move to logrotate.

Note You need to log in before you can comment on or make changes to this bug.