Bug 1025205 - BVT: smb mount is failing for glusterfs.x86_64 0:3.4.0.37rhs-1.el6rhs
BVT: smb mount is failing for glusterfs.x86_64 0:3.4.0.37rhs-1.el6rhs
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-devel (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Raghavendra Talur
Lalatendu Mohanty
: Regression, ZStream
Depends On:
Blocks: 1024496
  Show dependency treegraph
 
Reported: 2013-10-31 05:02 EDT by Lalatendu Mohanty
Modified: 2013-11-27 10:44 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.39rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:44:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-10-31 05:02:11 EDT
Description of problem:

SMB mount is failing with latest glusterfs.x86_64 0:3.4.0.37rhs-1.el6rhs

mount -t cifs \\\\10.70.40.130\\gluster-testvol /mnt/cifs
Password: 
Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


Version-Release number of selected component (if applicable):

glusterfs.x86_64 0:3.4.0.37rhs-1.el6rhs

How reproducible:

Always

Steps to Reproduce:
1. Install RHSS ISO RHSS-2.1-20131023.n.0 i.e. Use gluster packages previous to 3.4.0.37rhs-1
2. Create a gluster volume, start it
3. Verify that it is accessible. (mount it using smb in Linux/Windows client)
4. Stop the volume 
5. Update gluster and samba packages to latest i.e. glusterfs.x86_64 0:3.4.0.37rhs-1.el6rhs and amba-common-3.6.9-160.6.el6rhs.x86_64
6. Start the volume and try to to mount it.

Actual results:

Mount is failing.

Expected results:

Mount should happen successfully.

Additional info:
Comment 2 Raghavendra Talur 2013-10-31 07:52:36 EDT
This is because resolution of / is failing in glfs_resolve_at().
Comment 3 Gowrishankar Rajaiyan 2013-11-01 12:01:26 EDT
Patch URL please.
Comment 4 Vivek Agarwal 2013-11-04 05:13:24 EST
A patch posted by Avati for libgfapi had introduced this, and was removed. https://code.engineering.redhat.com/gerrit/#/c/14861/

https://bugzilla.redhat.com/show_bug.cgi?id=1024496
Comment 5 Raghavendra Talur 2013-11-06 04:34:10 EST
Patch posted for U1 at 
https://code.engineering.redhat.com/gerrit/#/c/15014/2

Patch posted for U2 at 
https://code.engineering.redhat.com/gerrit/15261
Comment 6 Lalatendu Mohanty 2013-11-07 04:09:06 EST
Verified on build glusterfs-3.4.0.39rhs. Smb mount can be done from Windows and Linux.
Comment 8 errata-xmlrpc 2013-11-27 10:44:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.