Bug 102524 - Kernels in beta1 and 2.4.21-1.1931.2.377 are unreliable
Summary: Kernels in beta1 and 2.4.21-1.1931.2.377 are unreliable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-16 14:58 UTC by H.J. Lu
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-26 00:06:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description H.J. Lu 2003-08-16 14:58:16 UTC
I found more "make check" failures in redhat gcc 3.3 under
EL 3.0 beta1 kernel. I even put 2.4.21-1.1931.2.377 on RH9.
I got new failures:

[hjl@gnu build-i686-linux]$ ./gcc/xgcc -v
Reading specs from /usr/gcc-3.3-redhat/lib/gcc-lib/i686-pc-linux-
gnu/3.3.1/specs
Configured with: /export/gnu/src/gcc-3.3-redhat/gcc/configure --enable-
clocale=gnu --with-system-zlib --enable-shared --enable-threads=posix --enable-
haifa --disable-checking --prefix=/usr/gcc-3.3-redhat --with-local-
prefix=/usr/local
Thread model: posix
gcc version 3.3.1 20030814 (Red Hat Linux 3.3.1-2)
[hjl@gnu build-i686-linux]$ grep FAIL ../nohup.out
FAIL: Array_3 execution - source compiled test
FAIL: Array_3 execution - gij test
FAIL: Array_3 execution - bytecode->native test
FAIL: Array_3 -O execution - source compiled test
FAIL: Array_3 execution - gij test
FAIL: Array_3 -O execution - bytecode->native test
FAIL: Divide_1 execution - source compiled test
FAIL: Divide_1 execution - bytecode->native test
FAIL: Divide_1 -O execution - source compiled test
FAIL: Divide_1 -O execution - bytecode->native test
FAIL: Invoke_1 execution - source compiled test
FAIL: Invoke_1 execution - bytecode->native test
FAIL: Invoke_1 -O execution - source compiled test
FAIL: Invoke_1 -O execution - bytecode->native test
FAIL: PR218 execution - source compiled test
FAIL: PR218 execution - gij test
FAIL: PR218 execution - bytecode->native test
FAIL: PR218 -O execution - source compiled test
FAIL: PR218 execution - gij test
FAIL: PR218 -O execution - bytecode->native test
FAIL: Throw_2 execution - source compiled test
FAIL: Throw_2 execution - gij test
FAIL: Throw_2 execution - bytecode->native test
FAIL: Throw_2 -O execution - source compiled test
FAIL: Throw_2 execution - gij test
FAIL: Throw_2 -O execution - bytecode->native test

I didn't see those failures under 2.4.20-19.9.

Comment 1 Jakub Jelinek 2003-08-16 19:22:38 UTC
These errors are intermitent, I saw them with various kernels and both gcc 3.2.x and
3.3.x.

Comment 2 H.J. Lu 2003-08-18 16:17:47 UTC
I believe it is a kernel/nptl related problem. When I ran "make check"
for the current glibc + nptl from CVS under the 2.4.21-1.1931.2.377 SMP
kernel on an SMP machine running RHEL 3.0 beta1, I got kernel oops during
nptl tests.

Comment 3 H.J. Lu 2003-08-18 18:36:07 UTC
I believe it is a kernel/nptl related problem. When I ran "make check"
for the current glibc + nptl from CVS under the 2.4.21-1.1931.2.377 SMP
kernel on an SMP machine running RHEL 3.0 beta1, I got kernel oops during
nptl tests.

Comment 4 Susan Denham 2003-08-18 18:43:39 UTC
Please retest with the .393 kernel that was posted to RHN (sushi) Thursday 8/14.
 Arun to provide to HJ.


Comment 5 H.J. Lu 2003-09-15 18:12:19 UTC
2.4.21-1.1931.2.423 seems OK.

Comment 6 Matt Wilson 2003-09-26 00:06:52 UTC
closing due to reporter feedback of newer kernel being ok



Note You need to log in before you can comment on or make changes to this bug.