Bug 1025241 - Typo in rhc help cartridge-scale
Typo in rhc help cartridge-scale
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 06:03 EDT by Jianwei Hou
Modified: 2015-05-14 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:28:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2013-10-31 06:03:15 EDT
Description of problem:
Run rhc help cartridge-scale, a typo was noticed
"You may pecify both values with the argumen" I guess 'pecify' probabaly means 'specify'

Version-Release number of selected component (if applicable):
rhc-1.16.6

How reproducible:
Always

Steps to Reproduce:
1. rhc help cartridge-scale

Actual results:
In the 3rd line of description "Set both values the same to guarantee a scale value.  You may pecify both values with the argument 'multiplier' or use '--min' and '--max' independently."

the 'pecify' is probably intended as 'specify'


Expected results:
Should have a new gear with haproxy component added to the gear.

Additional info:
Comment 1 Jianwei Hou 2013-10-31 06:07:39 EDT
sorry, please ignore the Expected results field in above description
Comment 2 Jordan Liggitt 2013-11-12 10:36:53 EST
Will merge in https://github.com/openshift/rhc/pull/510
Comment 4 weiwei jiang 2013-11-12 21:54:42 EST
Tried on devenv_4027 with rhc build from it, and results as follow:

# rhc cartridge scale -h
Usage: rhc cartridge-scale <cartridge> [multiplier] [--namespace NAME] [--app NAME] [--min min] [--max max]

Each cartridge capable of scaling may have a minimum and a maximum set, although within that range each type
of cartridge may make decisions to autoscale.  Web cartridges will scale based on incoming request traffic -
see https://www.openshift.com/developers/scaling for more information. Non web cartridges such as databases
may require specific increments of scaling (1, 3, 5) in order to properly function.  Please consult the
cartridge documentation for more on specifics of scaling.

Set both values the same to guarantee a scale value.  You may specify both values with the argument
'multiplier' or use '--min' and '--max' independently.

Scaling may take several minutes or more if the server must provision multiple gears. Your operation will
continue in the background if your client is disconnected.


Options
  -a, --app NAME            Name of an application
  -n, --namespace NAME      Name of a domain
  --min min                 Minimum scaling value
  --max max                 Maximum scaling value
  -c, --cartridge cartridge The name of the cartridge you are scaling

Global Options
  -l, --rhlogin LOGIN       OpenShift login
  -p, --password PASSWORD   OpenShift password
  --token TOKEN             An authorization token for accessing your account.
  --server NAME             An OpenShift server hostname (default: openshift.redhat.com)
  --timeout SECONDS         The timeout for operations

  See 'rhc help options' for a full list of global options.


So, verified this issue.

Note You need to log in before you can comment on or make changes to this bug.