This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025248 - default_floating_pool not configured
default_floating_pool not configured
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: async
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
: Triaged
Depends On: 1023399
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 06:15 EDT by Jaroslav Henner
Modified: 2016-04-26 17:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1023399
Environment:
Last Closed: 2013-12-19 19:33:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2013-10-31 06:15:40 EDT
+++ This bug was initially created as a clone of Bug #1023399 +++

Description of problem:
openstack-packstack-2013.2.1-0.12.dev806.fc20.noarch 
does not configures the 'default_floating_pool'.

How reproducible:
$ packstack --allinone 
$ nova boot server --flavor 1 --image 2f24b030-46bd-4667-8559-df7b684e9099
$ nova floating-ip-create 
ERROR: FloatingIpPoolNotFound: Floating ip pool not found. (HTTP 404) (Request-ID: req-4a97bf53-a878-4d6c-913e-14915dd087a0)
$ nova floating-ip-pool-list 
+--------+
| name   |
+--------+
| public |
+--------+

Actual results:
 Floating IP creation failing if the pool does not specified explicitly.

Expected results:
 Floating IP allocated from the default (public) pool.

Additional info:

Workaround:
openstack-config --set /etc/nova/nova.conf DEFAULT default_floating_pool public
service openstack-nova-api restart
Comment 2 Ivan Chavero 2013-11-16 00:03:39 EST
This bug has already been resolved, if you try with the new package you will see that there's a command line switch --novanetwork-default-floating-pool and a CONFIG_NOVA_NETWORK_DEFAULTFLOATINGPOOL configuration directive.
Comment 4 Scott Lewis 2013-11-19 11:54:33 EST
Auto adding >= MODIFIED bugs to beta
Comment 9 Nir Magnezi 2013-12-19 07:06:28 EST
Tested NVR: openstack-packstack-2013.2.1-0.20.dev936.el6ost.noarch

Verification Steps:
===================
1. packstack --allinone
2. launch an instance

Result:
=======
1. Check nova.conf for default pool configuration

# grep default_floating_pool /etc/nova/nova.conf 
#default_floating_pool=nova

=> not configured.

2. Steps executed in comment #0

# nova floating-ip-create
ERROR: FloatingIpPoolNotFound: Floating ip pool not found. (HTTP 404) (Request-ID: req-587b55d3-ce46-4819-a00c-7a858ae33661)
# nova floating-ip-pool-list
+--------+
| name   |
+--------+
| public |
+--------+
Comment 11 errata-xmlrpc 2013-12-19 19:33:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.