Bug 102525 - anaconda does not build
anaconda does not build
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-16 11:27 EDT by Michael Redinger
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-16 17:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2003-08-16 11:27:58 EDT
The latest anaconda package (anaconda-9.0.5-0.RHEL.20030811191253.src.rpm)
cannot be compiled on Taroon (all updates applied as of Aug 16 2003) because of
a compile error:


make[1]: Leaving directory `/usr/local/es/taroon/RedHat/BUILD/anaconda-9.0.5/fonts'
gcc -o mini-wm mini-wm.c `pkg-config gtk+-x11-2.0 --cflags --libs` -Wall -Werror
gcc -Wall -o _xkb.o -O2 -fPIC -I/usr/include/python2.2 `pkg-config --cflags
gtk+-2.0` -c xkb.c  -Wall -Werror
cc1: warnings being treated as errors
xkb.c: In function `main':
xkb.c:222: warning: passing arg 1 of `__builtin_expect' makes integer from
pointer without a cast
xkb.c:226: warning: passing arg 1 of `__builtin_expect' makes integer from
pointer without a cast
make: *** [_xkb.so] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.78831 (%build)
Comment 1 Matt Wilson 2003-08-16 17:35:04 EDT
fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.