Bug 1025280 - mariadb55-mariadb-server installation error: cannot touch ‘/var/log/mariadb55-mariadb/mariadb.log’
mariadb55-mariadb-server installation error: cannot touch ‘/var/log/mariadb55...
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: mariadb (Show other bugs)
mariadb55
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Honza Horak
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 07:27 EDT by Branislav Blaškovič
Modified: 2014-06-04 03:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: mariadb55-mariadb-5.5.34-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 03:19:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2013-10-31 07:27:29 EDT
Description of problem:
touch cannot touch log file for mariadb55-mariadb-server because the directory path does not exists.

Version-Release number of selected component (if applicable):



Steps to Reproduce:
1. Install mariadb55-mariadb-server on clean system or delete /var/log/%{?scl_prefix}mariadb first


Actual results:
  Installing : mariadb55-mariadb-server-5.5.33a-1.el7.x86_64                                       10/11
  /bin/touch: cannot touch ‘/var/log/mariadb55-mariadb/mariadb.log’: No such file or directory
  warning: %post(mariadb55-mariadb-server-5.5.33a-1.el7.x86_64) scriptlet failed, exit status 1
  Non-fatal POSTIN scriptlet failure in rpm package mariadb55-mariadb-server-5.5.33a-1.el7.x86_64
    Installing : mariadb55-1-9.el7.x86_64                                                            11/11


Expected results:
Proper install

I've noticed this in spec file:
497 %post server
498 %systemd_post %{?scl_prefix}mariadb.service
499 /bin/chmod 0755 %{?_scl_root}/var/lib/mysql
500 /bin/touch /var/log/%{?scl_prefix}mariadb/mariadb.log

It's touching log file but it's not creating the path leading to it.
Comment 2 Honza Horak 2013-11-22 02:36:24 EST
There is a mixture of mysqld.log and mariadb.log files, so this needs to be fixed. mariadb55-mysqld.log seems to be the better way to go in RHSCL-1.1, since we want to be compatible with RHSCL-1.0. We can change the log file location to /var/log/mariadb55-mariadb/mariadb.log (corresponds with RHEL-7 base layout) in RHSCL-2.0.
Comment 4 Branislav Blaškovič 2014-02-05 03:30:20 EST
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Reinstall Process
Resolving Dependencies
--> Running transaction check
---> Package mariadb55-mariadb-server.x86_64 0:5.5.34-6.el6 will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                       Arch        Version            Repository   Size
================================================================================
Reinstalling:
 mariadb55-mariadb-server      x86_64      5.5.34-6.el6       errata       13 M

Transaction Summary
================================================================================
Reinstall     1 Package(s)

Total download size: 13 M
Installed size: 55 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction

  Installing : mariadb55-mariadb-server-5.5.34-6.el6.x86_64                 1/1 

  Verifying  : mariadb55-mariadb-server-5.5.34-6.el6.x86_64                 1/1 

Installed:
  mariadb55-mariadb-server.x86_64 0:5.5.34-6.el6                                

Complete!
:: [ 16:36:49 ] :: [ INFO    ] :: rlRun: command = 'yum reinstall -y mariadb55-mariadb-server'; exitcode = 0; expected = 0
:: [   PASS   ] :: Running 'yum reinstall -y mariadb55-mariadb-server' (Expected 0, got 0)
:: [   PASS   ] :: File '/var/tmp/tmp.OUpgG7MeUq' should not contain 'No such file or directory' 
:: [   PASS   ] :: File '/var/tmp/tmp.OUpgG7MeUq' should not contain 'failed' 
:: [   PASS   ] :: File '/var/tmp/tmp.OUpgG7MeUq' should not contain 'failure' 

Beaker job:
https://beaker.engineering.redhat.com/jobs/587499
Comment 6 errata-xmlrpc 2014-06-04 03:19:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0614.html

Note You need to log in before you can comment on or make changes to this bug.