Bug 102532 - kmail creates *phantom messages* in inbound and outgoing boxes.
kmail creates *phantom messages* in inbound and outgoing boxes.
Status: CLOSED CANTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kdenetwork (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-16 15:41 EDT by Elton Woo
Modified: 2007-07-26 20:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 20:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-08-16 15:41:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
kmail is set to load as one of the startup programs in Gnome.
Whenever I shutdown / exit the desktop with kmail running, at the
next login, kmail displays the same messages in my out or inbound 
box, however clicking on them, I get "no subject" and the message
is totally devoid of content.

Version-Release number of selected component (if applicable):
kdenetwork-3.1.3-3

How reproducible:
Always

Steps to Reproduce:
1. setup in gnome preferences to autostart kmail
2. logout, and login, or manually start kmail, fetch messages
3. logout and login again
    

Actual Results:  kmail loads with many messages including previously read /
deleted ones.
Clicking on these messages, and the header changes to "no subject", and
the "message" is totally empty.

Expected Results:  kmail should and load actual folder contents.

Additional info:

CPU: AMD Athlon Thunderbird 1.0g
Video card: 3D Force 32-b Plus (32 Mb AGP)
NVidia drivers version 1.0-4496
Monitor: Viewsonic 17
Resolution: 1024 x 768 @ 24-bit depth.
Kernel version: kernel-2.4.21-20.1.2024.2.1.nptl
Comment 1 Mohamed Eldesoky 2003-08-18 09:15:28 EDT
I assure that. 
And it happens with older kde-3.* versions too 
Comment 2 Hoyt Duff 2003-08-20 08:19:14 EDT
It occurrs in the Kmail inclluded with Mandrake 9.1 as well. The "no subject" 
messages block any sending of new messages until they are deleted. 
Comment 3 Elton Woo 2003-08-20 14:33:43 EDT
Today, sending a single message, I got the error: "unable to send message because
_no recipients_ was selected" (untrue). When I go to the outbox, I find 4
messages. Three of them are the "usual" no subject / empties, and once *those* are
deleted, then I was able to do "send queued messages", viz: my one outgoing message.
Comment 4 Elton Woo 2003-10-19 17:51:48 EDT
This problem is still present in Fedora Core Test3 (RH 9.0.95), 
version: kmail 1.5.4
Comment 5 Elton Woo 2003-11-09 14:36:04 EST
Still present in Fedora Core 1 (Yarrow)
versions: 
kdenetwork-3.1.4-1
kmail 1.5.4
I have kmail in my Gnome startup programs. I DO NOT exit kmail when
I exit Gnome. Upon login, kmail starts, and I have to clean out
phantom "no subject" messages in all my folders (incoming, outgoing,
draft, trash) , *otherwise*, I cannot send any new mail.

Also see:
http://bugs.kde.org/show_bug.cgi?id=52129
Comment 6 Jesse Keating 2003-11-11 15:52:04 EST
I can confirm that this exists in FC1 (Yarrow).  Part of my standard
"recover from hard exit" processes is to check the outbox for these
phantom messages.  This has been happening since RH8 days I think. 
Most likely though, it's an upstream bug, one that RH can't directly
fix.  Perhaps it would be prudent for somebody to get KDE's attention
on this, or even check KDE's bugzilla(?) for this issue?
Comment 7 Jesse Keating 2003-11-11 15:53:39 EST
Whoops, I see from Elton's report above that it has been brought to
KDE's attention.  Sorry.
Comment 8 Petr Rockai 2006-07-17 14:17:22 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 9 Bill Nottingham 2006-08-07 11:44:48 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.
Comment 11 Bill Nottingham 2007-07-26 20:16:40 EDT
Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.