Bug 1025328 - vault format was changed - new docs should reflect that
vault format was changed - new docs should reflect that
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: EAP 6.2.0
Assigned To: eap-docs
Russell Dickenson
: Documentation, EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 09:49 EDT by Tom Fonteyne
Modified: 2014-08-14 11:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 18-10-2013 01:17:41 Topic ID: 5359-458813 [Latest]
Last Closed: 2014-05-23 02:54:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Fonteyne 2013-10-31 09:49:29 EDT
Title: Store and Retrieve Encrypted Sensitive Strings in the Java Keystore

https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6-Beta/html-single/Administration_and_Configuration_Guide/index.html#Store_and_Retrieve_Encrypted_Sensitive_Strings_in_the_Java_Keystore

Describe the issue:

The format of the vaulted strings has changed (since 6.1.1)

Please update the existing steps 9 and 10

step 9:

********************************************
Vault Block:ds_ExampleDS
Attribute Name:password
Configuration should be done as follows:
VAULT::ds_ExampleDS::password::1
********************************************

step 10

in both the xml snippet and and the end of the text:

<password>${VAULT::ds_ExampleDS::password::1}</password>

Next section, Example 10.27

********************************************
Vault Block:DS
Attribute Name:thePass
Configuration should be done as follows:
VAULT::DS::thePass::1
********************************************

Example 28:

        user = "sa",
        password = "VAULT::DS::thePass::1",
        className = "org.h2.jdbcx.JdbcDataSource",
Comment 1 Scott Mumford 2014-02-16 21:37:49 EST
While the actual content change requested here is trivial, retrospectively amending the 6.1 doc to include both this change and the original 6.1-specific content, and ensuring all translated versions of the document are also updated, is not.

Removing the EasyFix flag. Issue has been referred to docs lead for review.
Comment 2 FIlip Bogyai 2014-05-23 02:54:33 EDT
This is already fixed in EAP 6.2 & 6.3 documentation, so closing this ticket as resolved.

Note You need to log in before you can comment on or make changes to this bug.