Bug 1025345 - Deprecated options in the /usr/share/neutron/neutron-dist.conf
Deprecated options in the /usr/share/neutron/neutron-dist.conf
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Terry Wilson
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 10:13 EDT by Attila Fazekas
Modified: 2016-04-26 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-10 09:32:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1258307 None None None Never
Launchpad 1258308 None None None Never

  None (edit)
Description Attila Fazekas 2013-10-31 10:13:57 EDT
rpm -qf /usr/share/neutron/neutron-dist.conf 
openstack-neutron-2013.2-1.fc20.noarch

neutron-dist.conf contains multiple not working default options, inherited from the ages when neutron names was quantum.

$ sudo grep quantum /usr/share/neutron/neutron-dist.conf 
rpc_backend = quantum.openstack.common.rpc.impl_qpid
root_helper = sudo quantum-rootwrap /etc/quantum/rootwrap.conf

$ python
Python 2.7.5 (default, Oct  8 2013, 12:19:40) 
[GCC 4.8.1 20130603 (Red Hat 4.8.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import quantum.openstack
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named openstack

'quantum.openstack' package not exists.


$ ls -l /etc/quantum/rootwrap.conf
ls: cannot access /etc/quantum/rootwrap.conf: No such file or directory

The /etc/sudoers.d/neutron config does not allows to run quantum-rootwrap as neutron user.


Expected results:
rpc_backend = neutron.openstack.common.rpc.impl_qpid
root_helper = sudo quantum-rootwrap /etc/quantum/rootwrap.conf

Additional info:

/etc/neutron/neutron.conf also has multiple references to deprecated quantum named options.
Comment 3 Stephen Gordon 2013-12-09 23:17:30 EST
Terry when you get a moment can you please make sure this gets fixed up in RDO? A number of users have run into this issue and filed bugs against upstream documentation.
Comment 4 Terry Wilson 2013-12-11 15:51:07 EST
sgordon, actually this has already been fixed as of 2013.2-10. yay!
Comment 5 Stephen Gordon 2013-12-17 23:18:06 EST
(In reply to Terry Wilson from comment #4)
> sgordon, actually this has already been fixed as of 2013.2-10. yay!

When will that hit RDO Havana? Looking today the latest still seems to be openstack-neutron-2013.2-9.el6.noarch.rpm for EL6?
Comment 6 Terry Wilson 2013-12-18 10:46:48 EST
sgordon: I've had updated packages in the testing repos for a while now, but at this point it is out of my hands. There are a few people who can promote packages to the RDO repos now, and they're planning on doing commits more as batches as opposed to various packages being updated whenever. You might check with pbrady or apevec about the scheduling.
Comment 7 Stephen Gordon 2014-01-10 08:23:05 EST
Hi Padraig,

Any ETA on getting openstack-neutron-2013.2-10 into RDO?

Thanks,

Steve

Note You need to log in before you can comment on or make changes to this bug.