This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1025359 - cannot scroll in timezone list
cannot scroll in timezone list
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gtk3 (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: 7.3
Assigned To: Benjamin Otte
Desktop QE
:
: 1116101 1117847 (view as bug list)
Depends On:
Blocks: 986217 1230910 1295396 1297830 1313485 1283695 1364088
  Show dependency treegraph
 
Reported: 2013-10-31 10:30 EDT by Karel Volný
Modified: 2016-11-03 21:39 EDT (History)
15 users (show)

See Also:
Fixed In Version: gtk3-3.14.13-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
too high listing of cities (427.00 KB, image/png)
2013-10-31 10:30 EDT, Karel Volný
no flags Details
too high listing of cities (427.00 KB, image/png)
2014-07-31 11:55 EDT, IBM Bug Proxy
no flags Details
too high listing of cities (427.00 KB, image/png)
2014-08-18 08:21 EDT, IBM Bug Proxy
no flags Details
before changing region. (243.75 KB, image/png)
2015-05-28 15:21 EDT, IBM Bug Proxy
no flags Details
after changing region (233.93 KB, image/png)
2015-05-28 15:21 EDT, IBM Bug Proxy
no flags Details
/tmp/ from anaconda install on x86_64 (63.53 KB, application/x-compressed-tar)
2015-05-28 15:22 EDT, IBM Bug Proxy
no flags Details
/var/log/ from anaconda install on x86_64 (16.30 KB, application/x-compressed-tar)
2015-05-28 15:22 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Karel Volný 2013-10-31 10:30:03 EDT
Created attachment 817930 [details]
too high listing of cities

Description of problem:
Trying to set correct time zone for me (see bug #1025354), I've found I cannot do that via mouse, as the listing is higher than the screen and it does not scroll.

Version-Release number of selected component (if applicable):
latest nightly

How reproducible:
always

Steps to Reproduce:
1. in the installer go to date time settings
2. select e.g. Europe
3. try to choose the city of Prague

Actual results:
you cannot hover the mouse over Prague, as the list ends with Minsk

Expected results:
if the screen height is not enough, the list displays multiple columns, or provides means to scroll, so you can select e.g. Prague

Additional info:
see the screenshot
Comment 1 David Shea 2013-10-31 10:37:47 EDT
Reassigning to gtk3 since there isn't anything on anaconda's side that should prevent this ComboBox from being scrollable.

bug 1021509 is the corresponding bug for Fedora.
Comment 4 RHEL Product and Program Management 2014-03-22 02:34:22 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Máirín Duffy 2014-03-22 23:04:36 EDT
Ondrej - from a UX point of view, I agree this is bad issue. IIRC the list doesn't jump when you type letters either.
Comment 6 David Shea 2014-07-03 14:20:43 EDT
*** Bug 1116101 has been marked as a duplicate of this bug. ***
Comment 7 Joseph Kachuck 2014-07-03 16:12:48 EDT
Hello,
Can IBM be added to this BZ?

Thank You
Joe Kachuck
Comment 8 David Shea 2014-07-09 09:53:30 EDT
*** Bug 1117847 has been marked as a duplicate of this bug. ***
Comment 9 Karel Volný 2014-07-17 07:57:27 EDT
(In reply to Joseph Kachuck from comment #7)
> Hello,
> Can IBM be added to this BZ?

as RHEL7 is out and this is getting public duplicates, I see no reason to keep it private - opening and adding bugproxy@us.ibm.com to CC
Comment 10 IBM Bug Proxy 2014-07-31 11:55:03 EDT
Created attachment 922983 [details]
too high listing of cities

default comment by bridge
Comment 11 IBM Bug Proxy 2014-08-18 08:21:02 EDT
Created attachment 927843 [details]
too high listing of cities

default comment by bridge
Comment 14 Matthias Clasen 2015-05-28 14:24:27 EDT
this was fixed a while ago
Comment 16 IBM Bug Proxy 2015-05-28 15:21:57 EDT
Created attachment 1031382 [details]
before changing region.
Comment 17 IBM Bug Proxy 2015-05-28 15:21:59 EDT
Created attachment 1031383 [details]
after changing region
Comment 18 IBM Bug Proxy 2015-05-28 15:22:02 EDT
Created attachment 1031384 [details]
/tmp/ from anaconda install on x86_64
Comment 19 IBM Bug Proxy 2015-05-28 15:22:04 EDT
Created attachment 1031385 [details]
/var/log/ from anaconda install on x86_64
Comment 20 IBM Bug Proxy 2015-09-09 06:52:24 EDT
------- Comment From KATE@de.ibm.com 2015-09-09 10:44 EDT-------
Retested with RHEL7.2 B1

Original bug:
Fist time when you click on city to see city list - you can see navigation arrows and able to list this up and down.
Click on region and change it to another, or select the same, then click on city list again =>
there are no navigation arrows anymore.

Verification results:
First region Europe - you can see navigation arrows and able to list this up and down.
Change region to America -  you can see navigation arrows and able to list this up and down.
Change region back to Europe - you can see navigation arrows and able to list this up and down.
Looks good
******************************************************

But what I noticed:
if you choose region with only short list of cities (example Indian Ocean or Antarctica), which should not be scrolled, only 1 page, and this is OK.
But if you right after that go to Europe or America for example (with long list of cities)-> scroll no longer works.

If after this failed step try another region with Europe or America for example (with long list of cities -> scroll no longer works.

So problem is only the next try after "short list".
Comment 21 Jan Stodola 2015-09-16 06:45:40 EDT
Moving back to ASSIGNED based on comment 20. I'm also able to reproduce on Snapshot2 with gtk3-3.14.13-13.el7
Comment 23 Matthias Clasen 2015-09-18 12:02:03 EDT
Thanks for the screenshots and screencast. Very useful for understanding the problem. This looks like a new issue. Moving to 7.3, since we're out of time for 7.2
Comment 30 errata-xmlrpc 2016-11-03 21:39:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html

Note You need to log in before you can comment on or make changes to this bug.