Bug 1025361 - yum update of samba-common package creates two extra backup smb configuration files (.rpmnew and .rpmsave)
yum update of samba-common package creates two extra backup smb configuration...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Jose A. Rivera
Lalatendu Mohanty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 10:31 EDT by Lalatendu Mohanty
Modified: 2015-05-13 12:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: samba-3.6.9-167.6.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, if you modified the smb.conf file and if you updated to a new version samba package having a new version of smb.conf file, you would see two new backup files namely, smb.conf.rpmnew and smb.conf.rpmsave. With this update, only a single backup smb.conf file is created after SAMBA package update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:58:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-10-31 10:31:40 EDT
Description of problem:
yum update of samba-common package creates two smb configuration files (.rpmnew and .rpmsave) i.e.smb.conf.rpmnew  smb.conf.rpmsave. Updating samba packages modifies smb.conf and creates smb.conf.rpmnew  smb.conf.rpmsave

This will confuse the user as two files are getting created from a single update.

smb.conf.rpmsave: This is created before modifying smb.conf to put (include = /etc/samba/rhs-samba.conf)

smb.conf.rpmnew: This is created if the default smb.conf is already modified by the user. But this files does not have "include = /etc/samba/rhs-samba.conf" line. So not sure validity of this file

Also smb.conf.rpmnew does not have required settings for rhs i.e. stat cache = No and kernel oplocks = No

testparm -s smb.conf.rpmnew 
Load smb config files from smb.conf.rpmnew
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
	workgroup = MYGROUP
	server string = Samba Server Version %v
	log file = /var/log/samba/log.%m
	max log size = 50
	idmap config * : backend = tdb
	cups options = raw

[homes]
	comment = Home Directories
	read only = No
	browseable = No

[printers]
	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	print ok = Yes
	browseable = No


Version-Release number of selected component (if applicable):

samba-common-3.6.9-160.6.el6rhs

How reproducible:

Always

Always

Steps to Reproduce:
1. Yum update samba packages from version<=3.6.9-160.3.el6rhs  to version>3.6.9-160.3.el6rhs (which is the case for rhs2.1 to rhs2.1U1
2.
3.

Actual results:


Expected results:

This will confuse the user as two files are getting created from a single update. 

We need to stream line this and give clear information to user


Additional info:
Comment 2 Lalatendu Mohanty 2013-12-26 06:21:09 EST
Updated Samba from samba-3.6.9-160.7.el6rhs.x86_64 to samba.x86_64 0:3.6.9-167.9.el6rhs. 

After the update only smb.conf.rpmnew file is present as the default smb.conf has changed between samba-3.6.9-160.7.el6rhs.x86_64 to samba.x86_64 0:3.6.9-167.9.el6rhs and no rpmsave file is present. Which is fine. 

Updated Samba from samba.x86_64 0:3.6.9-167.8.el6rhs to samba.x86_64 0:3.6.9-167.9.el6rhs. There are no rpmsave or rpmnew file present as expected.

Hence marking the bug as verified.
Comment 3 Pavithra 2014-01-06 05:52:41 EST
Can you please review the doc text for technical accuracy?
Comment 4 Raghavendra Talur 2014-01-06 06:10:29 EST
Doc text is accurate.
Comment 6 errata-xmlrpc 2014-02-25 02:58:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.