Bug 102537 - When CAPS LOCK is activated, alt+tab switching no longer works.
Summary: When CAPS LOCK is activated, alt+tab switching no longer works.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-16 21:16 UTC by Robert Banfield
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-17 14:41:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Banfield 2003-08-16 21:16:28 UTC
Description of problem:  When CAPS LOCK is activated, alt+tab switching no
longer works.

Version-Release number of selected component (if applicable): kernel 2.4.20-19.9


How reproducible:  All the time


Steps to Reproduce:
1.  Turn on CAPS LOCK
2.  Try alt+tab switching of windows (it doesn't work)
3.
    
Actual results:  Nothing happens


Expected results:  Alternate windows come into focus


Additional info:

Comment 1 Havoc Pennington 2003-08-17 14:41:58 UTC
This is fixed in newer metacity, will be fixed in next release.

2003-05-20  Havoc Pennington  <hp@pobox.com>
	
	* src/keybindings.c (meta_change_keygrab): the mask 
	display->ignored_modifier_mask wasn't being bound, 
	due to "<" instead of "<=" (most people didn't notice
	as display->ignored_modifier_mask included Scroll_Lock).
	Red Hat bugzilla #91301 reported by Youssef Makki

	* src/display.c (meta_change_button_grab): make corresponding
	change for button grabs.

As a workaround you can configure Scroll_Lock on mod5, if you know how to 
play with X keymaps.


Note You need to log in before you can comment on or make changes to this bug.