Bug 1025370 - grouping if needed and always in window-list changes windows order
grouping if needed and always in window-list changes windows order
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell-extensions (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: 7.0
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 10:48 EDT by Vladimir Benes
Modified: 2015-11-19 02:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:11:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 719933 None None None Never

  None (edit)
Description Vladimir Benes 2013-10-31 10:48:15 EDT
Description of problem:
if you change grouping type from when needed to always, order of windows in window panel is changed. This shouldn't happen

Version-Release number of selected component (if applicable):
3.8.4-2

How reproducible:
always

Steps to Reproduce:
1.open several windows
2.open gnome-shell-extension-prefs
3.go to window list and change from when space is limited to always

Actual results:
order of windows turn opposite

Expected results:
order should stay the same

Additional info:
Comment 1 RHEL Product and Program Management 2014-03-27 01:49:29 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Florian Müllner 2015-04-23 08:00:53 EDT
This was fixed upstream in 3.13.2, so it will be included by the GNOME rebase.
Comment 10 Rik Theys 2015-09-15 04:44:45 EDT
Hi,

Will this rebase take place in 7.2? I don't see any updated gnome packages in the beta?

Regards,

Rik
Comment 11 Florian Müllner 2015-09-18 09:32:50 EDT
(In reply to Rik Theys from comment #10)
> Will this rebase take place in 7.2?

Yes, 7.2 will ship GNOME 3.14.
Comment 12 errata-xmlrpc 2015-11-19 02:11:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.