Bug 1025392 - dist-geo-rep : No way to reset or unset the checkpoint once set.
dist-geo-rep : No way to reset or unset the checkpoint once set.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Amar Tumballi
Vijaykumar Koppad
: ZStream
Depends On: 1028675
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 11:16 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.40rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:45:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-10-31 11:16:13 EDT
Description of problem: Earlier, once the checkpoint was set it was able to reset or unset using command "gluster v geo <master> <slave-url> config \!checkpoint" 


Version-Release number of selected component (if applicable): glusterfs-3.4.0.37rhs-1


How reproducible: Happens everytime.


Steps to Reproduce:
1.Create and start a geo-rep relationship between master and slave. 
2.set config checkpoint
3.try to unset it using the command "gluster v geo <master> <slave-url> config \!checkpoint" 

Actual results: It doesn't have any effect.


Expected results: should be able to unset with that command. 


Additional info:
Comment 2 Amar Tumballi 2013-11-02 12:23:12 EDT
https://code.engineering.redhat.com/gerrit/15088
Comment 3 Vijaykumar Koppad 2013-11-05 05:48:48 EST
I tried it in the build  glusterfs-3.4.0.39rhs, it doesn't work.
Comment 4 Aravinda VK 2013-11-06 02:12:47 EST
Since we made the change not to restart when checkpoint changed. Checkpoint change will reflect in when checkpoint loop reads the value next time(a few seconds delay)
Comment 5 Aravinda VK 2013-11-06 02:16:22 EST
Please try the following:

1. Set checkpoint
2. Check the config values(checkpoint)
"gluster v geo <master> <slave-url> config
3. Reset the checkpoint
"gluster v geo <master> <slave-url> config \!checkpoint"
4. Check the config values using
"gluster v geo <master> <slave-url> config


Amar, in your patch we may need to remove "checkpoint_target" along with the "checkpoint_completed"
Comment 7 Vijaykumar Koppad 2013-11-12 02:37:06 EST
verified on glusterfs-3.4.0.43rhs-1. Now it can be reset using the command "gluster v geo <master> <slave-url> config \!checkpoint"
Comment 8 errata-xmlrpc 2013-11-27 10:45:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.