Bug 1025408 - dist-geo-rep : glusterd crashes while resetting the geo-rep config options
dist-geo-rep : glusterd crashes while resetting the geo-rep config options
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Vijaykumar Koppad
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 11:38 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.38rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:45:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-10-31 11:38:23 EDT
Description of problem: While resetting the geo-rep config option using the command "gluster v geo <master> <slave-url> config \!<option>", option can be anything other than checkpoint. 

This is the backtrace of glusterd 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[2013-10-31 15:04:20.234900] I [glusterd-geo-rep.c:1583:glusterd_get_statefile_name] 0-: Using passed config template(/var/lib/glusterd/geo-replication/master_10.70.43.159_slave/gsyncd.conf).
[2013-10-31 15:04:37.929266] I [glusterd-geo-rep.c:1583:glusterd_get_statefile_name] 0-: Using passed config template(/var/lib/glusterd/geo-replication/master_10.70.43.159_slave/gsyncd.conf).
pending frames:
frame : type(0) op(0)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-10-31 15:04:38configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.4.0.37rhs
/lib64/libc.so.6[0x3befa32960]
/lib64/libc.so.6[0x3befa85e04]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(glusterd_op_stage_gsync_set+0xe44)[0x7fc159b641a4]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(glusterd_op_stage_validate+0x1fb)[0x7fc159b2142b]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(gd_stage_op_phase+0xa6)[0x7fc159b762e6]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(gd_sync_task_begin+0x272)[0x7fc159b782b2]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(glusterd_op_begin_synctask+0x3b)[0x7fc159b7843b]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(__glusterd_handle_gsync_set+0x171)[0x7fc159b5d4f1]
/usr/lib64/glusterfs/3.4.0.37rhs/xlator/mgmt/glusterd.so(glusterd_big_locked_handler+0x3f)[0x7fc159b04dcf]
/usr/lib64/libglusterfs.so.0(synctask_wrap+0x12)[0x7fc15d5c4ad2]
/lib64/libc.so.6[0x3befa43bb0]
---------


>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Version-Release number of selected component (if applicable): glusterfs-3.4.0.37rhs-1


How reproducible: didn't try to reproduce. 


Steps to Reproduce:
1.Create and start a geo-rep relationship between master and slave 
2.set the geo-rep log-level to DEBUG 
3.reset it using the command "gluster v geo <master> <slave-url> config \!log-level"

Actual results: glusted crashes 


Expected results:It shouldn't crash glusterd 


Additional info:
Comment 3 Vijaykumar Koppad 2013-11-02 04:00:10 EDT
verified on glusterfs-3.4.0.38rhs
Comment 5 errata-xmlrpc 2013-11-27 10:45:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.