Bug 1025447 - Menu bar missing one selection from VM context menu. [NEEDINFO]
Menu bar missing one selection from VM context menu.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Shahar Havivi
Petr Kubica
:
Depends On: 818051
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:02 EDT by Paul Vine
Modified: 2016-04-19 21:29 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:29:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: needinfo? (mrao)


Attachments (Terms of Use)
code: MainTabVirtualMachineView.java (51.61 KB, image/png)
2013-11-01 16:12 EDT, Einav Cohen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45403 master MERGED webadmin: added "console options" to the VMs main tab Never
oVirt gerrit 45423 ovirt-engine-3.6 MERGED webadmin: added "console options" to the VMs main tab Never

  None (edit)
Description Paul Vine 2013-10-31 14:02:29 EDT
Description of problem: Context menu for a VM has a selection called console options but menu bar does not. All other selections besides this are duplicated from the context menu to the menu bar. Why would this be singled out and only included on the context menu which makes it hard to find?


Version-Release number of selected component (if applicable): IS19


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Einav Cohen 2013-11-01 16:12:51 EDT
Created attachment 818457 [details]
code: MainTabVirtualMachineView.java
Comment 2 Einav Cohen 2013-11-01 16:14:50 EDT
from looking at the code in MainTabVirtualMachineView.java, it seems to be this way by design (see attachment 818457 [details]).

@Michal - do you recall the reason for that?
Comment 3 Michal Skrivanek 2013-11-06 10:31:21 EST
just not to clutter the menu bar, since the name is a bit long. The options are reachable via user portal easily so we thought it's better to sacrifice this in favor of screen estate
Comment 4 Paul Vine 2013-11-06 11:05:04 EST
In terms of relative importance I would think console options might be higher than others already displayed there. Consider using an icon.
Comment 5 Einav Cohen 2013-11-06 19:36:39 EST
I agree with Paul on the importance. But this particular issue depends on adding an infrastructure to support a large amount of buttons in the action-panel, which is tracked via Bug 818051 (marking this BZ as depends on Bug 818051);
Comment 6 Michal Skrivanek 2013-11-07 04:26:45 EST
(In reply to Paul Vine from comment #4)
> In terms of relative importance I would think console options might be
> higher than others already displayed there. Consider using an icon.

icon's a good idea, however normally you should not be actually using the dialog any often, even as an admin
Comment 7 Michal Skrivanek 2014-02-28 04:26:27 EST
Malini, what's your opinion about the icon/button?
IMHO it's additional options and should not belong to an actions menu
Comment 8 Shahar Havivi 2015-08-27 07:48:16 EDT
After talking with Eldan decided to add a dropdown menu to the monitor toolbar icon with the console options.
Comment 9 Petr Kubica 2015-09-15 07:13:07 EDT
Verified in 3.6.0-12

Note You need to log in before you can comment on or make changes to this bug.