Bug 102545 - Redhat 8.0 and 9.0 Terminal Color Problem
Redhat 8.0 and 9.0 Terminal Color Problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-17 03:03 EDT by Leonard Burns IV
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-17 21:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard Burns IV 2003-08-17 03:03:45 EDT
Description of problem:
I've been using a purchased copy of Redhat 7.2 on my systems for quite awhile 
now and had no problems, a friend came by the other day and loaned me his RH 
8.0 discs, so I decided to  upgrade my installation, and now all my term colors 
are broken. Before when linux booted up in a text format, you'd see the startup 
messages where the hardware posted and it finally came to the point where it 
would load up services and it'd say:

Setting up eth0 connection:   [ OK ]

The [ OK ] part was always a bright bold green, now its dark green, all my reds 
are now dark red, and so on. It screws up all my 'ls' colors and telnet colors, 
like dark white (grey) shows up as pure black making it unreadable on a black 
background so I've been trying to get it back to how it was since its a problem 
for me. I've messed around with the /etc/DIR_COLORS, /etc/DIR_COLORS.xterm 
files and that doesn't change anything no matter if I set say the color 
for '.tar' files to be bold or not bold, they're ALWAYS dark. Now I know its a 
problem because I can change the color, I make it it show '.tar' files as 
green, but again, no bold, only dark. I thought it might've been a software 
problem, so I reinstalled onto a clean machine, fresh format, and voila same 
exact problem. Reformatted, went back to 7.2, and there my bright bold colors 
were back, I compared files and they were identical, it just appears 8.0, and 
subsequently 9.0 which i tried a few hours ago, has this 'bold' color problem 
where it will ONLY show the dark colors in the term window.

Thought I'd pass this on, see if you guys could get this fixed for the next 
release, I know its something minor, and insignificant, but it'd mean a whole 
lot to this end user, and its also nice to just fix the bugs like this that 
happen to pop up. =)

Version-Release number of selected component (if applicable):
Redhat Linux 8.0, 9.0

How reproducible:
Everytime

Steps to Reproduce:
1.See above
    
Actual results:
1.See above


Expected results:
1.See above


Additional info:
Can contact me via e-mail or call me for a walkthrough to see how this happens. 
541-747-9040 name is Leonard Burns.
Comment 1 Bill Nottingham 2003-08-17 21:10:38 EDT
This is because of the switch to unicode; using extra characters for fonts on
the console does not allow for the use of the bold colors.

Note You need to log in before you can comment on or make changes to this bug.