Bug 1025456 - mirror device failure scenarios lead to deadlocks (part 2)
mirror device failure scenarios lead to deadlocks (part 2)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
cluster-qe@redhat.com
: TestBlocker
Depends On: 1009700
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:24 EDT by Corey Marthaler
Modified: 2016-04-08 17:19 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1009700
Environment:
Last Closed: 2015-03-26 12:14:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jonathan Earl Brassow 2014-07-25 22:54:43 EDT
The test listed in the last comment seems to fail one device first and then a second.  The second failure happens while the mirror is being up-converted due to the first repair.

I need to know a couple things to determine whether to fix this issue:
1) is it reproducible (It'd be useful to see those results and compare)
2) what is the result of the failure?  Is the mirror usable at that point or not?  Failure at an intermediate stage would be the same as bug 1016296, and I would likely close WONTFIX if there is no solution.  (RAID does not suffer from these issues.)

It is possible that we just need to cope with the fact that the final repair is called on the up-converting tmp image.  This could be a simple fix but depends on the answer to #2.
Comment 2 Jonathan Earl Brassow 2014-08-26 11:48:12 EDT
Moving to rhel6.7 for further consideration.  Whether to close or not will depend on the answers to the questions in comment 1.
Comment 4 Jonathan Earl Brassow 2015-03-26 12:14:12 EDT
(In reply to Jonathan Earl Brassow from comment #2)
> Moving to rhel6.7 for further consideration.  Whether to close or not will
> depend on the answers to the questions in comment 1.

Closing WONTFIX.

You are welcome to reopen this bug to be reconsidered if answers are provided to comment 1.
Comment 6 Corey Marthaler 2016-04-08 17:19:50 EDT
Filed bug 1325457 for the specific multiple asynchronous mirror device failures mentioned in that last few comments of this bug.

Note You need to log in before you can comment on or make changes to this bug.