Bug 1025467 - SD is partially accessible after extending.
SD is partially accessible after extending.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.5
Assigned To: Sergey Gotliv
Aharon Canan
storage
: ZStream
Depends On: 1022976 1023206
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 14:50 EDT by Chris Pelland
Modified: 2016-02-10 12:47 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
After adding a new LUN to the existing storage domain (both FC and iSCIS BlockSD are affected) hosts (except SPM) became non-operational. VMs started to migrate but mostly failed. The domainMonitor thread might have been using stale lvm filters while running the vgs command after extending of the VG (added PV is missed in the filter set).Since LvmCache doesn't invalidate filters, the volume group is marked as partial and domainMonitor selftest fails (host goes to non-operational status). By design, the filter should be invalidated if cmd returns a nonzero code, but vgs returns zero even if the devices are filtered . The patch introduces a public method for filter invalidation and calls it from the getDevicesVisibility, because getDevicesVisibility is called on all DC hosts after adding a new device but before extendSD.
Story Points: ---
Clone Of: 1022976
Environment:
Last Closed: 2013-12-18 08:58:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 522173 None None None Never
oVirt gerrit 20552 None None None Never

  None (edit)
Comment 4 Aharon Canan 2013-11-28 08:56:43 EST

verified using sf22
Comment 7 errata-xmlrpc 2013-12-18 08:58:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1832.html

Note You need to log in before you can comment on or make changes to this bug.