Bug 1025489 - samba-common should not create a smb.conf.rpmsave file on first time install
samba-common should not create a smb.conf.rpmsave file on first time install
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: RHGS 2.1.2
Assigned To: Jose A. Rivera
Lalatendu Mohanty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 15:34 EDT by Lalatendu Mohanty
Modified: 2015-05-13 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: samba-3.6.9-167.6.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, after a fresh Red Hat Storage installation, a backup file named smb.conf.rpmsave was seen. With this update, smb.conf.rpmsave backup file is not seen.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:58:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-10-31 15:34:07 EDT
Description of problem:

samba-common-3.6.9-160.6.el6rhs.x86_64 is creating smb.conf and smb.conf.rpmsave when it is installing for first time. That means if we install RHS U1 ISO, you will find smb.conf and smb.conf.rpmsave files present in /etc/samba. Where as it should be only smb.conf file as it is new install and there is no way user can have some settings in it.

The root cause of this issue is , while we are creating the .rpmsave file in the %post section of spec file , we are not checking if it is first time install or not.

Version-Release number of selected component (if applicable):

samba-common-3.6.9-160.6.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install RHSS-2.1-20131031.n.0
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Lalatendu Mohanty 2013-12-24 05:16:08 EST
Checked with samba-common-3.6.9-167.8.el6rhs.x86_64. The fresh install of samba-common is not creating rpmsave file.
# ls /etc/samba/
lmhosts  rhs-samba.conf  smb.conf  smbusers

Hence marking it verified.
Comment 3 Pavithra 2014-01-06 05:56:12 EST
Can you please review the doc text for technical accuracy?
Comment 4 Raghavendra Talur 2014-01-06 06:10:23 EST
Doc text is accurate.
Comment 6 errata-xmlrpc 2014-02-25 02:58:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.