Bug 1025497 - Instructions are not complete for the picketlink-sts quickstart
Instructions are not complete for the picketlink-sts quickstart
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: EAP 6.2.0
Assigned To: sgilda
Vladimir Rastseluev
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 15:56 EDT by sgilda
Modified: 2014-01-12 19:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:18:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sgilda 2013-10-31 15:56:48 EDT
Description of problem:

In the README file, under "Access the Application", it says:

The application will be running at the following URL http://localhost:8080/jboss-picketlink-sts/.

When you access the URL, you get a login prompt, but there is nothing in the README to tell you what to use or where to find valid usernames and passwords.

If you find the users.properties file and use one of names in the list, you see this:

This webpage is not found; No webpage was found for the web address: http://localhost:8080/jboss-picketlink-sts/  Error code: ERR_FILE_NOT_FOUND

Anil said this example is meant to be accessed as a web service. He and Pedro Igor will provide more information about how to use the application. I will update the instructions for login and create an index and add the provided info.

1. Add an index.html saying something nice that this should be accessed via the web
2. Update the README with more details about how it works and how to login.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 sgilda 2013-11-01 11:03:17 EDT
I updated the README file with Pedro Igor's information and rearranged the instructions to flow better. 

The index.html fix is not as simple as I expected. Since the PicketLinkSTS servlet maps to the url-pattern '/*', the index.html file is not displayed on success. I will need help from Pedor Igor or Anil with that one.

My current changes are pushed here; 

https://github.com/sgilda/jboss-as-quickstart/tree/Bz1025497-picketlink-sts-instructions
Comment 2 sgilda 2013-11-04 14:09:19 EST
Rather than add an index file, I changed the README to indicate that this is a service application with no UI, so the 'webpage not found' is the expected result on login.
Comment 3 sgilda 2013-11-05 07:20:16 EST
Changed Target milestone to CR1 as there is no ER8.
Comment 4 Jitka Kozana 2013-11-15 06:24:39 EST
6.2.0.CR1.
I can confirm the instructions how to access the application is now complete.

However, exceptions are logged in server.log after user logged in. For this issue I have opened a new BZ #1030937.

Closing this one as verified.

Note You need to log in before you can comment on or make changes to this bug.