Bug 1025503 - Updated openssl disables ssh-agent
Updated openssl disables ssh-agent
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 16:14 EDT by Salvatore La Bua
Modified: 2015-02-17 13:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 13:58:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Salvatore La Bua 2013-10-31 16:14:31 EDT
Description of problem:
After updating from version 1.0.1e-28 to either 29 or 30, ssh-agent won't start at login anymore.

Version-Release number of selected component (if applicable):
1.0.1e-29
1.0.1e-30

How reproducible:
Update openssl, openssl-devel, openss-libs to version 1.0.1e-29 or 1.0.1e-30

Steps to Reproduce:
Have a rsa/dsa key protected by passphrase
1. execute ssh-add -l
or
2. ssh into a machine that uses rsa/dsa key authentication
or
3. push a commit to github, or equivalently any other operation that would grant access via key authentication

Actual results:
Passphrase is being asked every time a login is attempted.

Expected results:
No passphrase should be asked.

Additional info:
Downgrading to 1.0.1e-28 without any other change, for me systematically fixes the issue, whilst upgrading to 1.0.1e-29 or 1.0.1e-30 breaks it again.
Comment 1 Tomas Mraz 2013-11-01 04:37:30 EDT
This is extremely improbable. The one and only difference between openssl-1.0.1e-28 and -29 is that -29 does not advertise ec curves that it does not support in TLS. SSH however does not have any relation to this functionality. Have you tried to restart the machine with the new openssl installed? The bug would have to be in build environment changes between -28 and -29 which is very improbable.

If you try to start the ssh-agent manually with ssh-agent -d - does it output any error? What exit code does it exit with if it does not start?
Comment 2 Salvatore La Bua 2013-11-03 04:45:05 EST
Hi, yes I tried to reboot but the result is the same.
Furthermore, starting the agent manually returns:

SSH_AUTH_SOCK=/tmp/ssh-UCs8zqHhEnnX/agent.11010; export SSH_AUTH_SOCK;
echo Agent pid 11010;

but after it, a ssh-add -l returns:

Could not open a connection to your authentication agent.
Comment 3 Salvatore La Bua 2013-11-03 19:39:43 EST
I just tried that in order to make it work, i first have to run:

eval $(ssh-agent)

then add the keys with:

ssh-add
(passphrase is asked now once)

then:

ssh-add -l

shows the cached keys.

Not sure why this happens, I run gnome-shell as desktop environment on fedora 19.
May this be related on some service autostart?
Comment 4 Fedora End Of Life 2015-01-09 15:25:06 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-17 13:58:34 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.