Bug 1025575 - Documentation: "Backing up a Red Hat Satellite Server" directory/files list is incomplete
Documentation: "Backing up a Red Hat Satellite Server" directory/files list i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
560
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Megan Lewis
Dan Macpherson
: Triaged
Depends On:
Blocks: sat-docs
  Show dependency treegraph
 
Reported: 2013-10-31 19:25 EDT by Xixi
Modified: 2015-07-07 20:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-07 20:00:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 11069 None None None Never

  None (edit)
Description Xixi 2013-10-31 19:25:06 EDT
Description of problem:

While updating the KnowledgeBase solution https://access.redhat.com/site/solutions/11069 "What files and directories are important during migration/backup of my Red Hat Satellite Server?", noticed the following:

Satellite documentation for back-ups, e.g, Satellite 5.6 User Guide "Chapter 3. Planning for Disaster Recovery" https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/5.6/html/User_Guide/chap-Red_Hat_Satellite-User_Guide-Planning_for_Disaster_Recovery.html is missing some files and directories under "3.1. Backing up a Red Hat Satellite Server" which starts with:

"Minimal Backup
Red Hat recommends that you back up at least the following files and directories:

    /var/lib/pgsql/: Embedded database only.
    /etc/sysconfig/rhn/
    /etc/rhn/
    /etc/sudoers
    /var/www/html/pub/
    /var/satellite/redhat/[0-9]*/ (This is the location of any custom RPMs)
    /root/.gnupg/
    /root/ssl-build/
    /etc/dhcp.conf
    /etc/httpd
    /tftpboot/
    /var/lib/cobbler/
    /var/lib/rhn/kickstarts/
    /var/www/cobbler
    /var/lib/nocpulse/ "

The following files/directories appear to be missing from the list:

/etc/tomcat*/ - This directory contains the Servlet Container (Tomcat) configuration files.

/etc/jabberd/ - This configuration contains configuration files for RHN Push Functionality.

/etc/cobbler/ - This directory contains configuration files for Cobbler.

Also, should the entire /var/www/ be backed up?
/var/www/ - This directory contains static Web Server content, Client SSL certificates, bootstrap scripts and much more.

There's also Oracle only config files, which I'm not sure if should be in the documentation since Satellite 5.6 comes with PostgreSQL and only supports Oracle database in the external db deployment option.

/etc/tnsnames.ora - (Oracle database only) Configuration file that defines addresses for establishing connections to the Oracle Database.

So, needing devel review to make sure the list is complete as of Satellite 5.6.

Version-Release number of selected component (if applicable):
Satellite 5.6

How reproducible:
Always.

Steps to Reproduce:
1. Go to https://access.redhat.com/site/documentation/en-US/Red_Hat_Satellite/5.6/html/User_Guide/chap-Red_Hat_Satellite-User_Guide-Planning_for_Disaster_Recovery.html#sect-Red_Hat_Satellite-User_Guide-Backing_up_a_Red_Hat_Satellite_Server
2.
3.

Actual results:
The list of file/directories is incomplete.

Expected results:
Complete list.

Additional info:
Comment 1 Xixi 2013-10-31 19:30:04 EDT
FWIW, this was the list from the kbase https://access.redhat.com/site/solutions/11069 which was engineering-verified (with jsherill, IIRC) as of Satellite 5.4 or 5.3.

"...
3. In addition, the following files and directories are important if a user wants to migrate or make a backup of the Red Hat Network Satellite server:

    /etc/sysconfig/rhn/ - This directory contains registration files and the Satellite server certificate.

    /etc/rhn/ - Important configuration files for the Satellite Server are stored in this directory.

    /etc/tnsnames.ora - Configuration file that defines addresses for establishing connections to the Oracle Database.

    /etc/httpd/ - This directory contains the Web Server (Apache, or httpd) configuration files.

    /etc/tomcat5/ - This directory contains the Servlet Container (Tomcat) configuration files.

    /etc/jabberd/ - This configuration contains configuration files for RHN Push Functionality.

    /etc/sudoers - This files specifies sudo priviledges for both human and daemon users on the system.

    /var/www/ - This directory contains static Web Server content, Client SSL certificates, bootstrap scripts and much more.

    /root/ssl-build/ - This directory contains Server and Client SSL certificates and keys.

    /root/.gnupg/ - This directory contains GPG keys.

    /var/satellite/ - This directory is the RHN Satellite package repository containing kickstart trees and RPMs .

    /rhnsat/ - This directory contains the Oracle database data and log files (embedded only).

    /opt/apps/oracle/config/10.2.0/ - This directory contains Oracle configuration files (note the "10.2.0" part will differ depending on Oracle version).

    ~nocpulse/ and /etc/nocpulse These directory contains RHN Monitoring related data as well as ssh private key for nocpulse user

    Note: From RHN Satellite v5.3.0 onwards nocpulse users home directory is /var/lib/nocpulse

Addtionally for Red Hat Network Satellite v5.3.0 following directories are important :

    /var/lib/rhn/kickstarts - This directory contains the kickstart files creating using the wizard, uploading through the web-ui and snippets.

    /var/lib/cobbler - This directory contains the cobbler configuration, snippets as well as kickstart files.

    /etc/cobbler/ - This directory contains configuration files for Cobbler.
..."
Comment 2 Dan Macpherson 2014-01-21 10:19:29 EST
This bug can be worked on early during the planning stages for Satellite 5.7.

Note You need to log in before you can comment on or make changes to this bug.