Bug 102558 - libmimelib.so symbolic link is missing from kdenetwork
libmimelib.so symbolic link is missing from kdenetwork
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kdenetwork (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-17 18:36 EDT by Felipe Alfaro Solana
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 10:55:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2003-08-17 18:36:12 EDT
Description of problem: 
The "kdenetwork" package from Red Hat does not contain the following symbolic 
link: 
 
/usr/lib/libmimelib.so -> /usr/lib/libmimelib.so.1 
 
This missing symbolic link causes some programs, like KMess, to fail during 
build as they link against libmimelib (using gcc's -lmimelib). During the 
build, GNU LD tries to link against /usr/lib/libmimelib.so but since it does 
not exist, it fails. 
 
Version-Release number of selected component (if applicable): 
3.1.3-1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Check that the "kdenetwork" package does not install 
"/usr/lib/libmimelib.so" file as a symbolic link to "/usr/lib/libmimelib.so.1" 
     
Actual results: 
/usr/lib/limemimelib.so does not exist and this causes programs that link 
against it to fail. 
 
Expected results: 
/usr/lib/libmimelib.so should be included in the kdenetwork package as a 
symbolic link to /usr/lib/libmimelib.so.1 
 
Additional info:
Comment 1 Ngo Than 2003-09-02 10:55:23 EDT
it's fixed in 3.1.3-4. thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.