Bug 1025611 - ASIX AX88179 Driver appears to have large packet lose with multiple USB devices. Unusable [NEEDINFO]
ASIX AX88179 Driver appears to have large packet lose with multiple USB devic...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 00:53 EDT by Brian D. Domenick
Modified: 2014-03-10 10:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 10:45:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michele: needinfo? (bdomenick)


Attachments (Terms of Use)

  None (edit)
Description Brian D. Domenick 2013-11-01 00:53:00 EDT
Description of problem:Ethernet is unusable on Startech USB3 dongle or SIIG hub with built in ethernet. Both device use ASIX AX88179 chipset. Driver from Asix website worked properly with Fedora 18 with older versions of driver. Later versions on Asix website produce the same problem as the built in version with Fedora 19. Devices show up properly, dhcp address is achieved. Ping loses 1 to 3 packets every 3 packets, very slow as well. This is with near, known to be good servers to ping. USB3 ethernet devices with this chipset are not usable with this driver. This chipset is probably one of the most common USB3 devices out there. The test computer was lenovo X1 Carbon


Version-Release number of selected component (if applicable):
Fedora 19 all updates as of yesterday, tried plugables driver as well with same results. Older version of Asix driver worked fine with Startech device on same laptop with Fedora 18. Newer Asix versions had broken behavior even with Fedora 18.

How reproducible:
Constant

Steps to Reproduce:
1.Plug in device, attach to network, get dhcp address
2.start a ping and observe output, Very slow, some missing packets, other internet stuff unusable.
3.

Actual results:


Expected results:
Fast ping, usable Ethernet performance


Additional info:
Comment 1 Michele Baldessari 2013-11-17 13:43:29 EST
Hi Brian,

can you be a bit more specific as to which kernel versions used to work properly
and which one started misbehaving?

So either it is due to a usb/net change or a specific driver change.
The driver itself did not have all too many changes lately:
 git lg --no-merges v3.6..HEAD drivers/net/usb/asix*
* 55d10a1 - (2013-08-13 14:13:52 -0700)  net: asix: Move declaration of ax88172a_info to shared header <Mark Brown>
* a88c32a - (2013-07-27 20:10:57 -0700)  USBNET: centralize computing of max rx/tx qlen <Ming Lei>
* c5060ce - (2013-05-03 16:10:33 -0400)  asix: fix BUG in receive path when lowering MTU <holger@eitzenberger.org>
* eae6591 - (2013-04-11 15:57:16 -0400)  usbnet: asix: apply usbnet_link_change <Ming Lei>
* 45af3fb - (2013-02-27 13:10:35 -0500)  usb/net/asix_devices: Add USBNET HG20F9 ethernet dongle <Glen Turner>
* ad32791 - (2013-01-19 11:00:29 -0500)  net: asix: ax88772_unbind() can be static <Wu Fengguang>
* 8b5b6f5 - (2013-01-18 14:13:29 -0500)  net: asix: handle packets crossing URB boundaries <Lucas Stach>
* 5620df6 - (2013-01-18 14:13:29 -0500)  net: asix: init ASIX AX88772B MAC from EEPROM <Lucas Stach>
* 7826d43 - (2013-01-06 21:06:31 -0800)  ethtool: fix drvinfo strings set in drivers <Jiri Pirko>
* 452b5ec - (2012-11-23 14:29:51 -0500)  asix: use ramdom hw addr if the one read is not valid <Jean-Christophe PLAGNIOL-VILLARD>
* 0bc69ef - (2012-10-26 03:36:50 -0400)  usbnet: asix: apply introduced usb command APIs <Ming Lei>
* 66dc81e - (2012-10-01 17:33:00 -0400)  asix: Adds support for Lenovo 10/100 USB dongle. <Quinlan Pfiffer>
* 49ae25b - (2012-09-20 17:53:14 -0400)  USB: remove dbg() usage in USB networking drivers <Greg Kroah-Hartman>

So if it is a driver issue only, it will be pretty simply to understand which change broke things. First we need
the versions where it worked and the ones where it broke.

Thanks,
Michele
Comment 2 Justin M. Forbes 2014-03-10 10:45:45 EDT
*********** MASS BUG UPDATE **************

This bug has been in a needinfo state for more than 1 month and is being closed with insufficient data due to inactivity. If this is still an issue with Fedora 19, please feel free to reopen the bug and provide the additional information requested.

Note You need to log in before you can comment on or make changes to this bug.