Bug 1025633 - Product cert is missing when fresh install rhel7.0 server x86_64
Product cert is missing when fresh install rhel7.0 server x86_64
Status: CLOSED DUPLICATE of bug 1026304
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: beta
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: TestBlocker
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-11-01 02:44 EDT by xingge
Modified: 2016-09-19 22:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 11:22:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xingge 2013-11-01 02:44:05 EDT
Description of problem:
Product cert is missing when fresh install rhel7.0 server x86_64

Version-Release number of selected component (if applicable):
RHEL7.0-Server-x86_64-20130130

How reproducible:
always

Steps to Reproduce:
1.Install the rhel7.0 system
2.list the product cert
#ls /etc/pki/product/


Actual results:
nothing is listed.

Expected results:
the product cert should be listed

Additional info:
Comment 1 xingge 2013-11-01 03:46:08 EDT
In fact there is no /etc/pki/product/ folder when I first installed the system. The folder is created after I registered the system to the stage candlepin server.
Is there some new mechanism to get the product cert that I don't know?
Comment 2 John Sefler 2013-11-06 16:21:28 EST
I am also seeing this failure.

I did a Minimal install from http://download.devel.redhat.com/nightly/latest-RHEL-7/compose/Server/x86_64/os/ and a Server GUI install from http://download.devel.redhat.com/nightly/latest-RHEL-7/compose/Everything/x86_64/os/ and despite the fact that there *is* a repodata/productid file in the compose tree, it does not get installed by anaconda to /etc/pki/productid 


I noticed the following in the anaconda logs that there was no sign of the product-id yum plugin being loaded (only see blacklist, langpacks, whiteout)...

[root@jsefler-7everything-gui ~]# grep "Loaded plugins" /var/log/anaconda/*.log
/var/log/anaconda/anaconda.packaging.log:19:22:27,428 INFO_2 yum.verbose.YumPlugins: Loaded plugins: blacklist, langpacks, whiteout
/var/log/anaconda/anaconda.packaging.log:19:22:27,734 INFO_2 yum.verbose.YumPlugins: Loaded plugins: blacklist, langpacks, whiteout
/var/log/anaconda/anaconda.packaging.log:19:25:12,824 INFO_2 yum.verbose.YumPlugins: Loaded plugins: blacklist, langpacks, whiteout
/var/log/anaconda/anaconda.packaging.log:19:25:27,996 DEBUG packaging: Loaded plugins: blacklist, langpacks, whiteout


However after the system reboots, a yum transaction shows the product-id loads...

[root@jsefler-7everything-gui ~]# yum repolist | grep "Loaded plugins"
Loaded plugins: langpacks, product-id, subscription-manager
Comment 3 Dennis Gregorovic 2013-11-06 19:07:56 EST
I'm guessing this is an anaconda issue.
Comment 4 xingge 2013-11-06 23:28:02 EST
I use web install from this url: "http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.0-20131030.1/compose/Server/x86_64/os/" which should be the same with url: "http://download.englab.nay.redhat.com/rel-eng/RHEL-7.0-20131030.1/compose/Server/x86_64/os/"

I tried to install with "server with gui" option but there are some dependency problem, so I chose the "minimal install"
Comment 6 Brian Lane 2013-11-08 11:22:45 EST

*** This bug has been marked as a duplicate of bug 1026304 ***

Note You need to log in before you can comment on or make changes to this bug.