Bug 1025645 - Both GPL and LGPL license files are required for LGPLv2+ project
Both GPL and LGPL license files are required for LGPLv2+ project
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Docs (Show other bugs)
development
Unspecified Unspecified
low Severity low
: ---
: 3.4
Assigned To: Ding-Yi Chen
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 03:33 EDT by Ding-Yi Chen
Modified: 2014-07-17 02:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points:
Clone Of:
Environment:
Last Closed: 2014-07-17 02:39:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-11-01 03:33:42 EDT
Description of problem:
Zanata uses LGPLv2+ license and has LGPL license file.
However quote from http://www.gnu.org/licenses/gpl-howto.html
  
   You should also include a copy of the license itself somewhere in the distribution of your program. All programs, whether they are released under the GPL or LGPL, should include the text version of the GPL. In GNU programs the license is usually in a file called COPYING.

   If you are releasing your program under the LGPL, you should also include the text version of the LGPL, usually in a file called COPYING.LESSER. Please note that, since the LGPL is a set of additional permissions on top of the GPL, it's important to include both licenses so users have all the materials they need to understand their rights.


In other words, both GPL and LGPL license files are required.


Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1. https://github.com/zanata/zanata-server/master
2.
3.

Actual results:
Contains only LGPL (filename: License.txt)

Expected results:
Contains both GPL (filename: License.txt)
and LGPL (filename: License.Lesser.txt)


Additional info:
Comment 1 Damian Jansen 2014-03-04 20:52:55 EST
Any update on this?
Comment 2 David O'Brien 2014-03-04 22:07:48 EST
I'm not sure why this is a doc bug. It seems that one copy of each license needs to be included in the distribution somewhere. If there's something specific you need me to do from a doc perspective pls let me know.
Comment 3 Ding-Yi Chen 2014-03-04 22:53:35 EST
David, I don't think you need to write any document.
Comment 4 Ding-Yi Chen 2014-03-12 03:59:37 EDT
https://github.com/zanata/zanata-server/pull/394
Comment 5 Ding-Yi Chen 2014-05-01 00:27:34 EDT
https://github.com/zanata/zanata-server/pull/427

Note You need to log in before you can comment on or make changes to this bug.