Bug 1025659 - To fix the modulization job
To fix the modulization job
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity unspecified
: ER5
: 6.0.0
Assigned To: Roger Martínez
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 04:30 EDT by Ryan Zhang
Modified: 2015-06-01 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bpm_server.log (92.43 KB, text/x-log)
2013-11-01 04:31 EDT, Ryan Zhang
no flags Details
brms_server.log (13.62 KB, text/x-log)
2013-11-01 04:32 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Ryan Zhang 2013-11-01 04:30:09 EDT
Description of problem:
I have  assembled a prototype of ER5 in Jenkins with latest modulization job. And See the following error by starting the server. 

The jenkins job provided two ER5 standalone distributions(EAP 6.1.0 GA contained),Download link::
1) ER5 with modulized war(Found the following error, see details error in server.log)
BPM: https://repository.engineering.redhat.com/nexus/content/repositories/scratch-release-soa-brms-6-build/org/jboss/ip/jboss-bpms/6.0.0-redhat-5/jboss-bpms-6.0.0-redhat-5-bpms-standalone.zip

BRMS: https://repository.engineering.redhat.com/nexus/content/repositories/scratch-release-soa-brms-6-build/org/jboss/ip/jboss-brms/6.0.0-redhat-5/jboss-brms-6.0.0-redhat-5-brms-standalone-module.zip


2) ER5 with skinny war(No error is found). Download link:
BPM: https://repository.engineering.redhat.com/nexus/content/repositories/scratch-release-soa-brms-6-build/org/jboss/ip/jboss-bpms/6.0.0-redhat-5/jboss-bpms-6.0.0-redhat-5-bpms-standalone.zip
BRMS:
https://repository.engineering.redhat.com/nexus/content/repositories/scratch-release-soa-brms-6-build/org/jboss/ip/jboss-brms/6.0.0-redhat-5/jboss-brms-6.0.0-redhat-5-brms-standalone.zip

ErrorStack in BPMS:
15:59:56,703 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-11) MSC000001: Failed to start service jboss.deployment.unit."business-central.war".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."business-central.war".WeldStartService: Failed to start service
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05]
Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001409 Ambiguous dependencies for type [Event<InvalidateDMOPackageCacheEvent>] with qualifiers [@Default] at injection point [[field] @Inject private org.drools.workbench.screens.globals.backend.server.GlobalsEditorServiceImpl.invalidatePackageDMOEvent]. Possible dependencies [[Implicit Bean [javax.enterprise.event.Event] with qualifiers [@Default], Managed Bean [class org.jbpm.shared.services.impl.events.JbpmServicesEventImpl] with qualifiers [@Any @Default]]]
	at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:314)
	at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:280)
	at org.jboss.weld.bootstrap.Validator.validateBean(Validator.java:143)
	at org.jboss.weld.bootstrap.Validator.validateRIBean(Validator.java:163)
	at org.jboss.weld.bootstrap.Validator.validateBeans(Validator.java:382)
	at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:367)
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	... 3 more

ErrorStack in  BRMS:
15:45:23,138 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-14) MSC000001: Failed to start service jboss.deployment.unit."business-central.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."business-central.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "business-central.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05]
Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found
	at org.jboss.msc.service.ServiceContainerImpl.getRequiredService(ServiceContainerImpl.java:448) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.getDefaultResourceAdapterName(MessageDrivenComponentDescriptionFactory.java:270)
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processMessageDrivenBeanMetaData(MessageDrivenComponentDescriptionFactory.java:241)
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processBeanMetaData(MessageDrivenComponentDescriptionFactory.java:87)
	at org.jboss.as.ejb3.deployment.processors.AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.processBeanMetaData(AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.java:65)
	at org.jboss.as.ejb3.deployment.processors.AbstractDeploymentUnitProcessor.processDeploymentDescriptor(AbstractDeploymentUnitProcessor.java:143)
	at org.jboss.as.ejb3.deployment.processors.AbstractDeploymentUnitProcessor.deploy(AbstractDeploymentUnitProcessor.java:84)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
	... 5 more



Version-Release number of selected component (if applicable):


How reproducible:
Please download 
and start the server .

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2013-11-01 04:31:38 EDT
Created attachment 818176 [details]
bpm_server.log
Comment 2 Ryan Zhang 2013-11-01 04:32:36 EDT
Created attachment 818177 [details]
brms_server.log
Comment 4 Roger Martínez 2013-11-03 14:29:26 EST
Only as a comment, after the refactor done in modules distribution generation today (https://bugzilla.redhat.com/show_bug.cgi?id=1025416), I have tested all generated artifacts (BPMS/BRMS static modules ZIP and skinny WARs) and I have not found any error.

The application starts and runs as excepted.
Comment 5 Ryan Zhang 2013-11-03 21:32:34 EST
Ok, Great.
I will try the new code.
Comment 6 Roger Martínez 2013-11-04 15:02:56 EST
Ok Ryan, 

Please give me feedback about this issue... if with the new version you still have some problems, I will check it as soon as possible :)

Thanks in advance.

Roger
Comment 7 Roger Martínez 2013-11-07 18:11:34 EST
Hi Ryan,

As we have no feedback yet.. we consider this bug closed. 

Feel free to reopen it if necessary :)

Thanks
Comment 8 Ryan Zhang 2013-11-07 21:29:01 EST
Yep, Moving to MODIFIED is correct.
Sorry for no feedback yet. I have to test it after build all components in EAP 6.1.1. I will update this once I do the smoketest on this.
Comment 9 Ryan Zhang 2013-11-13 22:07:52 EST
By looking at the new prototype of ER5, this issue is fixed.
Thanks, Roger!
Comment 10 Jiri Svitak 2013-12-04 07:05:21 EST
This issue is rather internal one and doesn't have an impact on customers.

ER5 was released with EAP 6.1.1 module support. Verified.

Note You need to log in before you can comment on or make changes to this bug.