Bug 1025705 - JBossws MemoryBufferRecorderTestCase fails for IPv6 address in full format
JBossws MemoryBufferRecorderTestCase fails for IPv6 address in full format
Status: CLOSED WORKSFORME
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: EAP 6.3.0
Assigned To: Alessio Soldano
Rostislav Svoboda
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 06:58 EDT by Petr Sakař
Modified: 2014-10-25 08:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: The -b option to set the IPV6 address is continued to be support for backward compatibility. It is preferred that -Djboss.bind.address be used going forward however. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-27 09:03:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sakař 2013-11-01 06:58:06 EDT
Description of problem:
org.jboss.test.ws.management.recording.MemoryBufferRecorderTestCase#testGetRecordsByClientHost is failing when serverhost is [0:0:0:0:0:0:0:1]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run test from jbossws cxf stack version 4.2.2.Final-redhat-2  with EAP 6.2.0.ER7 with following setup

AS_NETWORK_CONFIG="-Djava.net.preferIPv4Stack=false -Djava.net.preferIPv6Addresses=true"
AS_STARTUP_PARAMS="-b=0:0:0:0:0:0:0:1 -bmanagement=0:0:0:0:0:0:0:1 -bunsecure=0:0:0:0:0:0:0:1"
BIND_PARAMS="-Djboss.bind.address=[0:0:0:0:0:0:0:1] -Djbossws.deployer.host=0:0:0:0:0:0:0:1 -Djava.net.preferIPv4Stack=false -Djava.net.preferIPv6Addresses=true"
CLI_PARAMS="controller=[0:0:0:0:0:0:0:1]"

Actual results:
test fails

Expected results:
test passes

Additional info:
The test was passing in 6.2.0.ER6, but commit 17989 broke it (see  https://source.jboss.org/changelog/JBossWS?cs=17989)
Offending line is line 136
      if ("[::1]".equals(host)) host = "0:0:0:0:0:0:0:1"; // IPv6 hack
because value of host is "[0:0:0:0:0:0:0:1]", the enclosing brackets are not stripped of.
The line should be replaced for test if address is IPv6 and if yes strip enclosing brackets and expand to full format if it is in short one, so the test would work with different IPv6 addresses then [::1] and [0:0:0:0:0:0:0:1] as well
Comment 1 Rebecca Searls 2014-03-27 08:31:40 EDT

> Petr skkar ...wrote
> I've sent to SVN commit [1].
> It fixes the issue, when the server is started with option -b=[::1] and the
> tests are failing complaing the host is not in format [::1].
> The "problem" is caused by current implementation of parameters parsing in
> eap, when -b=[::1] is converted to -Djboss.bind.address=::1, thus we can not
> satisfy your requirement without stopping using -b and setting directly via
> -Djboss.bind.address. That would meant for us to change all scripts / jobs.
> 
> Petr
> 
> 
> [1] https://source.jboss.org/changelog/JBossWS?cs=18545
Comment 2 Petr Sakař 2014-03-27 09:03:23 EDT
verified fixed in EAP 6.3.0.DR6

Note You need to log in before you can comment on or make changes to this bug.