Bug 102571 - when invoked, up2date end with Traceback info (python strings) and a TypeError: unsupported operand type(s) for -=: 'str' and 'int'
when invoked, up2date end with Traceback info (python strings) and a TypeErro...
Product: Red Hat Linux
Classification: Retired
Component: rhnlib (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
Depends On:
  Show dependency treegraph
Reported: 2003-08-18 03:01 EDT by Johan Sand
Modified: 2007-04-18 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-08-24 03:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johan Sand 2003-08-18 03:01:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After installing RH9.0, I wanted to update the system. First I tried the RHN
Alert Notification Tool which works fine until I click the "launch up2date"
button. Nothing happens - ever.

So I launched it from the shell, and after a couple of minutes it spits out
Python junk, starting with "Traceback (most recent call last):" and ending with
"TypeError: unsupported operand type(s) for -=: 'str' and 'int'" (see
"Additional Information").

I manually updated up2date and tried again - same result.
I manually updated everything else from the list generated by RHN Alert
Notification tool - same result (well, I grabbed the wrong arch version of glibc
once and had to reinstall the system, but anyways...)
I reinstalled the system - same result.
I reinstalled the system with different package selection (from WS to All
Packages) - same result.
No matter what I do, the error is the same - if I try it with or without
parameters, with or without packages to actually update, the error is still
there and always the same.

Version-Release number of selected component (if applicable):
up2date- python-2.2.2-26

How reproducible:

Steps to Reproduce:
1. Open a shell
2. Invoke up2date
3. Wait a few minutes

Actual Results:  After a couple of minutes I get an error dump in my shell
(see "Additional Information")

Expected Results:  When invoking up2date with packages to be updated, I expect
these to be updated

Additional info:

Here's the output up2date throws up after a couple of minutes
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 993, in ?
  File "/usr/sbin/up2date", line 612, in main
  File "up2dateAuth.py", line 112, in updateLoginInfo
  File "up2dateAuth.py", line 100, in login
  File "rpcServer.py", line 114, in doCall
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 142, in request
    fd = resp.decode(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 355, in decode
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 336, in read
    self.io = _smart_total_read(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 407, in
    chunk = fd.read(bufferSize)
  File "/usr/lib/python2.2/httplib.py", line 388, in read
    self.length -= amt
TypeError: unsupported operand type(s) for -=: 'str' and 'int'

Other facts (useful or not):
My box is a Dell Inspiron 7000 laptop standard HW config (256MB RAM, 8MB 2xAGP, etc)
I'm using NTP for accurate time (the result is the same with or without suing
NTP, with or without using UTC).

Right now the system is running with all updates available for my system
(according to RHN Alert...).

I have not yet compiled the kernel, but I figure up2date should work without
recompiling the kernel.

Comment 1 Mihai Ibanescu 2003-08-18 11:52:43 EDT
rhnlib bug.

Do you run on a wireless network card?
Comment 2 Johan Sand 2003-08-18 14:38:57 EDT
No I don't run on a wireless network card.
My network setup is pretty simple and as follows:
I have a Win2k box with two NICs - one for internal networking and one for
external (to ADSL to Internet). The internal network NIC acts, with an Internet
Router software, as Gateway for my other machines. My laptop has a normal D-Link
PCMCIA 10/100mbit NIC with which I connect to the Internet through the Gateway
on my winhog box.
All other network operations I've tried so far on my laptop works fine. I've
checked the log files of the router software on my winhog machine and there's
nothing unusual there. I've checked the log file of up2date (/var/log/up2date)
and there it says:
up2date updating login info
up2date loging into up2date server
And that's it. The other log files doesn't say anything regarding up2date.

Oh, yes, while trying up2date I have disabled my firewalls.
Comment 3 Johan Sand 2003-08-24 03:45:28 EDT
I haven't managed to determine the exact problem, but I assume that the
communication between RHN and my laptop suffer in one way or another when
running through my win box router software and the VPN tunnel. Could be an
authentication problem, lost packages, time-outs or what have you. Whatever it
is I can't tell, as all logs from all involved apps and interfaces looks ok and
all other network operations work the way they should.

The solution, however, was simply to setup my laptop as the primary "Internet

Even though this solution isn't ideal, since a) I don't want my home network to
be dependent on my laptop and b) I still think it should work with a normal NAT
configuration, I figure it's safe to say that all is fine and dandy now.

Thanks for your time and consideration.
Johan Sand

Note You need to log in before you can comment on or make changes to this bug.