Bug 1025729 - common block thread private variables out of scope inside OpenMP parallel region
common block thread private variables out of scope inside OpenMP parallel re...
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gcc (Show other bugs)
DTS 2.1 RHEL 6
All Linux
medium Severity medium
: alpha
: 3.1
Assigned To: Jakub Jelinek
Miroslav Franc
: Patch
Depends On: 1158876 1258713 533183 844959
Blocks: 1039566
  Show dependency treegraph
 
Reported: 2013-11-01 07:53 EDT by Dagmar Prokopová
Modified: 2015-09-01 01:33 EDT (History)
17 users (show)

See Also:
Fixed In Version: devtoolset-3-gcc-4.9.2-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, the OpenMP artificial functions generated by the compiler did not have the DW_AT_name attribute. Because of this, it was not possible to print variables residing in an OpenMP region in the GNU debugger. This has been fixed in such a way that DW_AT_name is properly set and now it is possible to print variables even in OpenMP regions.
Story Points: ---
Clone Of: 844959
Environment:
Last Closed: 2015-04-23 03:53:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Dagmar Prokopová 2013-11-01 07:59:31 EDT
The same issue appears in all versions of Red Hat Developer Toolset on both rhel5 and rhel6.
Comment 13 Marek Polacek 2014-12-11 11:05:02 EST
This is fixed in 4.9 branch, so should be fixed for DTS-3.1.
Comment 15 Marek Polacek 2015-01-09 14:00:38 EST
Fixed.
Comment 19 errata-xmlrpc 2015-04-23 03:53:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0880.html

Note You need to log in before you can comment on or make changes to this bug.