Bug 1025731 - Gnome calculator is not focused when started by a media key
Gnome calculator is not focused when started by a media key
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 08:00 EDT by Petr Kočandrle
Modified: 2014-12-05 13:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-05 13:03:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kočandrle 2013-11-01 08:00:05 EDT
Description of problem:
When I press Calculator key on my keyboard (or any other key on which is mapped Calculator start), the application starts, but no window has focus. When started as any other application from shell overview it is focused normally.

Version-Release number of selected component (if applicable):
gnome-calculator.x86_64 3.8.2-1.fc19
gnome-shell.x86_64 3.8.4-2.fc19

How reproducible:
Everytime.

Steps to Reproduce:
1. Start Calculator by a media-key as configured in Keyboard settings

Actual results:
The application's window is not focused.

Expected results:
The application's window is focused.

Additional info:
The problem was introduced by switch from F18 to F19.
Comment 1 Florian Müllner 2013-11-01 12:12:16 EDT
Fixed upstream in https://bugzilla.gnome.org/show_bug.cgi?id=704859 (and bugs linked from there). The fix will be included in the upcoming F20 release.

Note You need to log in before you can comment on or make changes to this bug.