Bug 1025733 - anaconda: BootLoaderError: failed to write bootloader configuration (iSCSI boot)
anaconda: BootLoaderError: failed to write bootloader configuration (iSCSI boot)
Status: CLOSED DUPLICATE of bug 1025500
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Jones
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-01 08:01 EDT by Bruno Goncalves
Modified: 2013-11-01 09:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 09:19:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (11.22 KB, text/plain)
2013-11-01 08:17 EDT, Bruno Goncalves
no flags Details
ifcfg.log (10.79 KB, text/plain)
2013-11-01 08:18 EDT, Bruno Goncalves
no flags Details
packaging.log (201.90 KB, text/plain)
2013-11-01 08:19 EDT, Bruno Goncalves
no flags Details
program.log (32.88 KB, text/plain)
2013-11-01 08:19 EDT, Bruno Goncalves
no flags Details
storage.log (153.09 KB, text/plain)
2013-11-01 08:21 EDT, Bruno Goncalves
no flags Details
syslog (135.66 KB, text/plain)
2013-11-01 08:21 EDT, Bruno Goncalves
no flags Details

  None (edit)
Description Bruno Goncalves 2013-11-01 08:01:27 EDT
Description of problem:
Trying to install RHEL7 on a iSCSI boot server causes an error when writing bootloader.

anaconda 19.31.31-1 exception report 
Traceback (most recent call first): 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1532, in write_config 
    raise BootLoaderError("failed to write bootloader configuration") 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1571, in write 
    self.write_config() 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2365, in writeBootLoader 
    storage.bootloader.write() 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 175, in doInstall 
    writeBootLoader(storage, payload, instClass, ksdata) 
  File "/usr/lib64/python2.7/threading.py", line 764, in run 
    self.__target(*self.__args, **self.__kwargs) 
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run 
    threading.Thread.run(self, *args, **kwargs) 
BootLoaderError: failed to write bootloader configuration 


Version-Release number of selected component (if applicable):
anaconda 19.31.31-1

How reproducible:
100%

Steps to Reproduce:
1.Start installing RHEL7 on iSCSI boot system.

2.Error happens at the end of the installation when "Installing bootloader"
Comment 1 David Shea 2013-11-01 08:09:35 EDT
Please attach the log files from /tmp to this bug.

This is probably a duplicate of bug 1025500
Comment 2 Bruno Goncalves 2013-11-01 08:17:52 EDT
Created attachment 818274 [details]
anaconda.log
Comment 4 Bruno Goncalves 2013-11-01 08:18:45 EDT
Created attachment 818276 [details]
ifcfg.log
Comment 5 Bruno Goncalves 2013-11-01 08:19:15 EDT
Created attachment 818277 [details]
packaging.log
Comment 6 Bruno Goncalves 2013-11-01 08:19:45 EDT
Created attachment 818278 [details]
program.log
Comment 7 Bruno Goncalves 2013-11-01 08:21:14 EDT
Created attachment 818279 [details]
storage.log
Comment 8 Bruno Goncalves 2013-11-01 08:21:34 EDT
Created attachment 818280 [details]
syslog
Comment 9 Samantha N. Bueno 2013-11-01 09:19:14 EDT
(In reply to David Shea from comment #1)
> Please attach the log files from /tmp to this bug.
> 
> This is probably a duplicate of bug 1025500

Yep, same message in program.log:

10:31:53,885 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
10:31:54,456 INFO program: Generating grub.cfg ...
10:31:54,457 INFO program: Found linux image: /boot/vmlinuz-3.10.0-40.el7.x86_64
10:31:54,457 INFO program: Found initrd image: /boot/initramfs-3.10.0-40.el7.x86_64.img
10:31:54,457 INFO program: /etc/grub.d/10_linux: line 83: 16bit=: command not found
10:31:54,457 DEBUG program: Return code: 127

*** This bug has been marked as a duplicate of bug 1025500 ***

Note You need to log in before you can comment on or make changes to this bug.